huu 1003Max Sum dp

Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
   
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
   
   
Case 1: 14 1 4 Case 2: 7 1 6

思路:在循环的过程中,每循环一次就算出一个以当前位置结束的最大子序列和。每次循环中最大的那个保存下来,就是最终所有最大子序列和中的最大值

#define _CRT_SBCURE_MO_DEPRECATE
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<functional> 
using namespace std;

int n, t;
int a[100050];
int sum;
int str, en, k;
int maxs;

int main()
{
	cin >> n;
	int temp = 1;
	int temp2 = n;
	while (n--) {
		cin >> t;
		sum = 0;
		maxs = -99999;
		str = en = k = 1;
		for (int i = 1; i <= t; i++)  cin >> a[i];
		for (int i = 1; i <= t; i++) {
			sum = sum + a[i];
			if (sum > maxs) { //现在的序列和比之前的最大子序列大;
				maxs = sum;
				//cout << maxl ;
				str = k;//开始位置就是上次序列和清零后重新开始新序列的地址
				en = i;//不管下一个加正还是负数,都会使下一个数增加;
				//cout << " " << en << endl;
			}
			if (sum <0) { //子序列和小于0,那么之后不管再加什么数,都会使下一个数减小;
				k = i + 1;//保存的是后一个位置的子序列和的开始位置
				sum = 0; // 序列和清零,从下一循环开始从新计算序列和
			}			
		}
		printf("Case %d:\n%d %d %d\n", temp, maxs, str, en);
		if (temp != temp2)cout << endl;
		temp++;
	}
	//system("pause");
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值