Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
Sample Input
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
Sample Output
3 ?
思路:最小生成树 畅通时,路线条数是村庄个数-1
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<functional>
#include<map>
using namespace std;
int father[105];
int n, m;
int ans;
struct node {
int a, b, len;
};
node edge[105];
int cmp(const node& a, const node& b) {
return a.len<b.len;
}
void makeSet() {
for (int i = 0; i <= 100; i++) father[i] = i;
}
int Find(int x) {
int root = x;
while (root != father[root]) {
root = father[root];
}
while (x != root) {
int tmp = father[x];
father[x] = root;
x = tmp;
}
return root;
}
void Union(int x, int y) {
int a = Find(x);
int b = Find(y);
if (a == b) return;
else {
father[a] = b;
}
}
int main()
{
while (scanf("%d %d", &n, &m) != EOF && n != 0) {
int a, b;
for (int i = 0; i < n; i++) {
scanf("%d %d %d", &edge[i].a, &edge[i].b, &edge[i].len);
}
sort(edge, edge + n, cmp);
makeSet();
ans = 0;
int k = 0;
for (int i = 0; i < n; i++) {
if (Find(edge[i].a) != Find(edge[i].b)) {//判断根节点是否一样
Union(edge[i].a, edge[i].b);//一样就表示可以间接畅通
ans += edge[i].len;
k++;//路线条数
}
}
//判断是否畅通
if (k == m-1)printf("%d\n", ans);
else printf("?\n");
}
//system("pause");
return 0;
}