hdu1874 畅通工程续 单源最短路算法——Dijkstra

连接:http://acm.hdu.edu.cn/showproblem.php?pid=1874

Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
  
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
  
  
2 -1

思路:Dijkstra算法 适用于边权为正,从单个源点出发,到所有节点的最短路径,有向图无向图均可

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<functional> 
#include<map>
using namespace std;
const int maxn = 10000 + 10;
const int INF = (int)1e9;

#define Min(x,y) ( (x) < (y) ? (x) : (y) )

struct node {
	int vex, weight;
	node(int a = 0,int b = 0):vex(a),weight(b){}
};

int n, m;
int s, t;
vector<node>G[maxn];
bool intree[maxn];
int mindist[maxn];

void init()
{
	for (int i = 0; i < maxn; i++) {
		intree[i] = false;
		G[i].clear();
		mindist[i] = INF;
	}
}

int Perim(int s, int t) {
	int ans = 0;
	int vex, addNode, tempMin;
	intree[s] = true;
	mindist[s] = 0;
	for (int i = 0; i < G[s].size(); i++) {//找开始点周围的路径并初始化
		vex = G[s][i].vex;
		mindist[vex] = Min(mindist[vex], G[s][i].weight);
	}
	for (int nodeNum = 1; nodeNum <= n - 1; nodeNum++) {//向周围n-1个点找
		tempMin = INF;
		for (int i = 0; i < n; i++) {
			if (intree[i] == false && mindist[i] < tempMin) {//寻找最短路径
				tempMin = mindist[i];
				addNode = i;
			}
		}
		intree[addNode] = true;
		for (int i = 0; i < G[addNode].size(); i++) {//更新
			vex = G[addNode][i].vex;
			if (intree[vex] == false && mindist[addNode] + G[addNode][i].weight < mindist[vex])
				mindist[vex] = mindist[addNode] + G[addNode][i].weight;
		}
	}
	if(intree[t]==true)	return mindist[t];
	else  return -1;
}

int main()
{
	while (scanf("%d %d", &n, &m)!=EOF) {
		init();
		for (int i = 0; i < m; i++) {
			int a, b, c;
			scanf("%d %d %d", &a, &b, &c);
			G[a].push_back(node(b, c));
			G[b].push_back(node(a, c));
		}
		scanf("%d %d", &s, &t);
		int sum;
		sum = Perim(s, t);
		printf("%d\n", sum);
	}
	//system("pause");
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值