poj 1106 Transmitters 计算几何

Description

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations.

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter.

Input

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

Output

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Sample Input

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5

Sample Output

3
4
4


题意:出平面中的一些点,然后给你一个圆(给出圆心坐标,半径),问若将这个圆划分为半圆,最多能容纳多少点。(点在半圆边上也算)

思路:先预判排除点到圆心距离大于半径的点 在利用两个for循环判断每个点到其他各店的叉积,大于0的即可,最后找max

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<functional> 
#include<map>
using namespace std;
const int maxn = 200 + 10;
const int INF = (int)1e9;
const double eps = 1e-9;

struct point {
	double x;
	double y;
};
point P[maxn];
point o;//圆心
point temp;

int dis(point a, point b) {//距离函数
	return sqrt((a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y));
}

double crossleft(point a, point b, point c) {//叉积函数
	return (a.x - b.x)*(c.y - b.y) - (a.y - b.y)*(c.x - b.x);
}

int main()
{
	double r;//半径
	int num;//点数
	while (scanf("%lf %lf %lf", &o.x, &o.y, &r) != EOF) {
		if (r < eps) break;
		int k = 0;
		scanf("%d", &num);
		while (num--) {
			scanf("%lf %lf", &temp.x, &temp.y);
			if (dis(temp, o) - r < eps) //距离满足条件
				P[k++] = temp;
		}
		int ans, Max = 0;
		for (int i = 0; i < k; i++) {
			ans = 0;
			for (int j = 0; j < k; j++) {
				if (crossleft(P[i], o, P[j]) >= 0)//判断叉积
					ans++;
			}
			Max = max(ans, Max);
		}
		printf("%d\n", Max);
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值