hdu3007Buried memory 最小圆覆盖 计算几何

链接:http://acm.hdu.edu.cn/showproblem.php?pid=3007

Problem Description
Each person had do something foolish along with his or her growth.But,when he or she did this that time,they could not predict that this thing is a mistake and they will want this thing would rather not happened.
The world king Sconbin is not the exception.One day,Sconbin was sleeping,then swakened by one nightmare.It turned out that his love letters to Dufein were made public in his dream.These foolish letters might ruin his throne.Sconbin decided to destroy the letters by the military exercises's opportunity.The missile is the best weapon.Considered the execution of the missile,Sconbin chose to use one missile with the minimum destruction.
Sconbin had writen N letters to Dufein, she buried these letters on different places.Sconbin got the places by difficult,he wants to know where is the best place launch the missile,and the smallest radius of the burst area. Let's help Sconbin to get the award.
 

Input
There are many test cases.Each case consists of a positive integer N(N<500,^V^,our great king might be a considerate lover) on a line followed by N lines giving the coordinates of N letters.Each coordinates have two numbers,x coordinate and y coordinate.N=0 is the end of the input file.
 

Output
For each case,there should be a single line in the output,containing three numbers,the first and second are x and y coordinates of the missile to launch,the third is the smallest radius the missile need to destroy all N letters.All output numbers are rounded to the second digit after the decimal point.
 

Sample Input
  
  
3 1.00 1.00 2.00 2.00 3.00 3.00 0
 

Sample Output
  
  
2.00 2.00 1.41
 
题意:给几个点,用一个最小的圆把这些点全部覆盖,求这个圆的圆心半径

思路:穷举法,最小圆覆盖必然是某三个顶点的外界圆,那么设置三层循环进行枚举就可以了!

  但是会出现下面的例外。

  

  也就是说三层遍历得到C(n,3)个外接圆,并不能够保证算法的正确性,我们还要构造C(n,2)个以两个点的连线为直径的圆。

  关于求解一个三角形的外接圆圆心:

  我们只需找到两条线段的中垂线然后求交点即可。



代码:

#include<iostream>  
#include<cmath>  
#include<cstdio>  
#include<algorithm>   
using namespace std;
const double eps = 1e-8;
struct Point {
	double x, y;
}p[505];
double dis(const Point &a, const Point &b)//求距离
{
	return sqrt((a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y));
}
Point circumcenter(const Point &a, const Point &b, const Point &c)//返回三角形的外心   
{ 
	Point ret;
	double a1 = b.x - a.x, b1 = b.y - a.y, c1 = (a1*a1 + b1*b1) / 2;
	double a2 = c.x - a.x, b2 = c.y - a.y, c2 = (a2*a2 + b2*b2) / 2;
	double d = a1*b2 - a2*b1;
	ret.x = a.x + (c1*b2 - c2*b1) / d;
	ret.y = a.y + (a1*c2 - a2*c1) / d;
	return ret;
}
void min_cover_circle(Point *p, int n, Point &c, double &r) { //c为圆心,r为半径   
	random_shuffle(p, p + n); //   
	c = p[0]; r = 0;//圆心为第一个点 半径为0
	for (int i = 1; i<n; i++)
	{
		if (dis(p[i], c)>r + eps)  //第一个点  
		{
			c = p[i]; r = 0;//更改圆心
			for (int j = 0; j<i; j++)
				if (dis(p[j], c)>r + eps) //第二个点  
				{
					c.x = (p[i].x + p[j].x) / 2;//圆心暂时位于两点中间
					c.y = (p[i].y + p[j].y) / 2;
					r = dis(p[j], c);//半径更新
					for (int k = 0; k<j; k++)
						if (dis(p[k], c)>r + eps) //第三个点
						{
							c = circumcenter(p[i], p[j], p[k]);//求外接圆圆心,三点必不共线   
							r = dis(p[i], c);
						}
				}
		}
	}
}
int main() {
	int n;
	Point c;
	double r;
	while (scanf("%d", &n) == 1 && n) {
		for (int i = 0; i<n; i++)
			scanf("%lf%lf", &p[i].x, &p[i].y);
		min_cover_circle(p, n, c, r);
		printf("%.2lf %.2lf %.2lf\n", c.x, c.y, r);
	}
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值