poj 3468 A Simple Problem with Integers(线段树,区间更新)

链接:http://poj.org/problem?id=3468

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 104996 Accepted: 32769
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

线段树,区间更新,模板,wa了一次也是因为getchar() TAT


代码:

#define _CRT_SBCURE_MO_DEPRECATE    
#include<iostream>    
#include<stdlib.h>    
#include<stdio.h>    
#include<cmath>    
#include<algorithm>    
#include<string>    
#include<string.h>    
#include<set>    
#include<queue>    
#include<stack>    
#include<functional>     
using namespace std;
const int maxn = 10000000 + 10;
const int INF = 0x3f3f3f3f;
typedef long long ll;

int a[maxn];
int t, n, q;
ll x, y, v, anssum;
char m;

struct node {
	ll l, r;
	ll addv, sum;
}tree[maxn << 2];

void maintain(int id)
{
	if (tree[id].l >= tree[id].r)
		return;
	tree[id].sum = tree[id << 1].sum + tree[id << 1 | 1].sum;
}

void pushdown(int id)
{
	if (tree[id].l >= tree[id].r)
		return;
	if (tree[id].addv) {
		int tmp = tree[id].addv;
		tree[id << 1].addv += tmp;
		tree[id << 1 | 1].addv += tmp;
		tree[id << 1].sum += (tree[id << 1].r - tree[id << 1].l + 1)*tmp;
		tree[id << 1 | 1].sum += (tree[id << 1 | 1].r - tree[id << 1 | 1].l + 1)*tmp;
		tree[id].addv = 0;
	}
}

void build(int id, ll l, ll r)
{
	tree[id].l = l;
	tree[id].r = r;
	tree[id].addv = 0;
	if (l == r)
	{
		tree[id].sum = a[l];
		return;
	}
	ll mid = (l + r) >> 1;
	build(id << 1, l, mid);
	build(id << 1 | 1, mid + 1, r);
	maintain(id);
}
void updateAdd(int id, ll l, ll r, ll val)
{
	if (tree[id].l >= l && tree[id].r <= r)
	{
		tree[id].addv += val;
		tree[id].sum += (tree[id].r - tree[id].l + 1)*val;
		return;
	}
	pushdown(id);
	ll mid = (tree[id].l + tree[id].r) >> 1;
	if (l <= mid)
		updateAdd(id << 1, l, r, val);
	if (mid < r)
		updateAdd(id << 1 | 1, l, r, val);
	maintain(id);
}

void query(int id, ll l, ll r)
{
	if (tree[id].l >= l && tree[id].r <= r) {
		anssum += tree[id].sum;
		return;
	}
	pushdown(id);
	ll mid = (tree[id].l + tree[id].r) >> 1;
	if (l <= mid)
		query(id << 1, l, r);
	if (mid < r)
		query(id << 1 | 1, l, r);
	maintain(id);
}

int main() {
	scanf("%d %d", &n, &q);
	memset(a, 0, sizeof(a));
	for (int i = 1; i <= n; i++)
		scanf("%d", &a[i]);
	build(1, 1, n);
	for (int j = 1; j <= q; j++) {
		getchar();
		scanf("%c", &m);
		if (m == 'C') {
			scanf("%lld %lld %lld", &x, &y, &v);
			updateAdd(1, x, y, v);
		}
		if (m == 'Q') {
			anssum = 0;
			scanf("%lld %lld", &x, &y);
			query(1, x, y);
			printf("%lld\n", anssum);
		}
	}
	
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值