微信小程序提示SSL证书https、TLS版本必须大于1.2的问题

微信小程序与第三方服务器通讯的域名的几个必要条件

1、加ssl证书,也就是https://~~~

2、HTTPS 服务器的 TLS 版本支持1.2及以下版本,一般就是1.0、1.1、1.2要同时支持这三个版本,一个也不能少,要不然就会出现下面这种情况


没有ssl证书的可以去下载免费的或购买,

查询tls信息, https://www.ssllabs.com/index.html  点击打开链接


另外说一下,TLS版本的问题,这个也是很多朋友经常掉的坑,我也掉过,然后直接去微软官网查了一下资料发现
windows服务器系统的2008R2以下都不支持,所以大家xp、20003系统什么的就不用折腾了,没用的~~

发一个windows对TLS版支持的状况图表

NOTE: Windows Server 2008 R2 and Windows 7 are the only 2 OS which support TLS 1.1 and TLS 1.2 as of now. All the OS’s before this don’t support these 2 protocols.


 

好了,看了这个图大家应该明白 什么系统可以用了~~


关于独立主机的配置教程:https://blog.csdn.net/qq_14913213/article/details/70756571 点击打开链接

腾讯云的配置教程参考:https://cloud.tencent.com/document/product/400/6973#1.nginx-.E8.AF.81.E4.B9.A6.E9.85.8D.E7.BD.AE 点击打开链接


展开阅读全文

没有更多推荐了,返回首页