使用maven创建项目和cannot change version web module 3.0

最近下载了最新的Eclipse mars.2, 这个eclipse自带了maven插件,于是就用maven尝试创建一个java web项目。

第一步,如下图所示选择 Maven Project, Next

第二步,注意Create a simple project不用打勾, Next

第三步,在Filter中输入web可以快速检索需要的archetypes,选中 然后Next

第四步,

Group Id  是指项目组唯一标识符,实际对应java包的结构

Aftifact Id 指项目唯一标识符,就是项目名称

Finish,完成一个项目的创建

以上为完成一个maven项目的流程,但是新创建的项目可能有一些错误,需要去调整,接下来继续说明

第一个错误:

刚刚创建的maven项目下 只有resource文件夹, src/main/java和  src/test/java 文件夹都是missing  (项目右键属性,在Java Build Path中的Order and Export选项卡中可见)

解决办法如下:

切换到Libraries选项卡,  选中JRE System Library[J2 SE - 1.5] 点击 右侧 Edit.. 

不采用默认的jdk, 选择Alternate JRE 中选择当前环境用的JDK(我自己用的jdk 1.7),  点击Finish 和 OK完成设置

missing 的文件夹已经出现:

接下来处理 jsp文件编译出错的问题

选中项目右键 属性 回到 Java Build Path窗口,不多说,看图


在这里我是提前配置好了tomcat7的,点击Finish , 然后Ok到结束,就完成了jsp编译的设置

一个新的maven项目创建完成。 刚创建好的项目, jdk版本还有 web.xml版本过低 jdk默认好像是1.5的, web.xml默认是2.3的

右键项目 -->  属性 -->  Project Facets

我的jdk版本是1.7 故java选择1.7 ,Dynamic Web Module选择3.0,jdk会设置成功, Dynamic web Module会发现设置不了, 

Cannot change version of project facet Dynamic web module to 3.0的错误

解决办法是: 

1.修改web.xml的文件内容为:

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns="http://java.sun.com/xml/ns/javaee"
xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd"
id="WebApp_ID" version="3.0">
 

</web-app>

2.在navigator的视图下 找到项目下的 .setting文件夹, 打开文件org.eclipse.wst.common.project.facet.core.xml, 将jdk从1.5修改为1.7,  jst.web修改成3.0

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="java" version="1.7"/>
  <installed facet="jst.web" version="3.0"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

这样就完成了修改,而且有效,但有个问题是一旦重新 点击 Maven --> Update Project.. 就一夜回到解放前了

所以需要pom.xml文件中,添加一段配置,这样就能保证 Maven --> Update Project..之后也正常了。

<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId>
    <version>3.5.1</version>
<configuration>
<source>1.7</source>
<target>1.7</target>
</configuration>
</plugin>
</plugins>
</build>

  • 0
    点赞
  • 0
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论

打赏作者

ming_love

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值