石思潮的博客

这世界就是一拨人在昼夜不停地高速运转,另一拨人起床发现世界变了。

Dynamic Web Module 是2.3,无法修改到3.0

eclipse 新SVN下来的项目,遇到了这样的问题:
这里写图片描述
打开
project > Properties >Project Facets 页面
提示下面的错误:
这里写图片描述
而Dynamic Web Module 是2.3,无法修改到3.0,Java 已经是1.7了
非常郁闷。
pom.xml里也已经有了配置:

    <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>2.3.2</version>
                <configuration>
                    <source>1.7</source>
                    <target>1.7</target>
                </configuration>
    </plugin>

如何解决问题?百度了很久,看了一些文章,基本方法就是改Java version,并在pom.xml中添加上述设置。但是不管用怎么办?
最后有一个终极方法直接修改Dynamic Web Module:
在navigator视图下找到.setting包下的org.eclipse.wst.common.project.facet.core.xml
修改

<installed facet="jst.web" version="2.3"/>

<installed facet="jst.web" version="3.0"/>

OK!

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/shi1451042748/article/details/52352884
文章标签: java eclipse
个人分类: JavaWeb
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

Dynamic Web Module 是2.3,无法修改到3.0

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭