HDU 5776 sum

Problem Description

Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO

Input

The first line of the input has an integer T (1 \leq T \leq 101T10), which represents the number of test cases. For each test case, there are two lines: 1.The first line contains two positive integers n, m (1 \leq n \leq 1000001n1000001 \leq m \leq 50001m5000). 2.The second line contains n positive integers x (1 \leq x \leq 1001x100) according to the sequence.

Output

Output T lines, each line print a YES or NO.

Sample Input
2
3 3
1 2 3
5 7
6 6 6 6 6
Sample Output
YES
NO

中文描述:


问题描述
给定一个数列,求是否存在连续子列和为m的倍数,存在输出YES,否则输出NO
输入描述
输入文件的第一行有一个正整数T(1\leq T \leq 101T10),表示数据组数。

接下去有T组数据,每组数据的第一行有两个正整数n,m (1\leq n\leq 1000001n100000 ,1\leq m\leq50001m5000).

第二行有n个正整数x (1\leq x\leq 1001x100)表示这个数列。
输出描述
输出T行,每行一个YES或NO。
输入样例
2
3 3
1 2 3
5 7
6 6 6 6 6
输出样例
YES
NO


#include <iostream>
#include <string.h>
using namespace std;
const int N=100005;
int a[N];
int main(){
	int t;
	scanf("%d",&t);
	
	
	int n,m;
	while(t--){
		bool flag=false;
		scanf("%d %d",&n,&m);
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
//			a[i]%=m; //会节省时间 
		}
		
		for(int i=0;i<n;i++){
			int sum=0;
			for(int j=i;j<n;j++){
				sum+=a[j];
				if(sum%m==0) {
					flag=true;
					break;
				}
			}
			if(flag) break;
		}
		
		if(flag) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
		
	}
	
}


这一题居然直接暴力不会T。。我感到十分震惊→_→;

节省实践的方法是在输入时对每个数字对m取模,如果取模相加和能整除,也一定能整除;

取模的时间是15ms,直接暴力是190+ms,所以优化起来肯定还是取模比较好;


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值