HDU 5831 Rikka with Parenthesis II



Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence  S , and he wants Rikka to choose two different position  i,j  and swap  Si,Sj

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
3 4 ())( 4 ()() 6 )))(((
 

Sample Output
  
  
Yes Yes No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
using namespace std;
const int N=100008;
char str[N];

int main(){
	int t,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		scanf("%s",str);
		int ans=0;
		bool flag=0;
		
		
		if(n==1){
			printf("No\n");
			continue;
		}
		if(n==2&&str[0]=='('&&str[1]==')'){
			printf("No\n");
			continue;
		}
		

		for(int i=0;i<n;i++){
			if(str[i]=='('){
				ans++;
			}
			else{
				ans--;
			}
			
			if(ans<-2){
			
				flag=1;
				
			}
		}
		if(ans!=0){
			printf("No\n");
			continue;
		}
		if(flag) printf("No\n");
		else printf("Yes\n");

		
	}
	
}
题意:给一串由‘(’和‘)’组成的序列,可以对序列中的两个位置进行交换一次,判断交换后的序列是否满足条件;

首先如果是括号个数是奇数,则一定不满足条件;如果为(),也不满足条件;

如果同时出现3个及以上的未配对的‘)’,也不能满足题意;那我们只要记录未配对的‘)’的个数即可;

如果有‘(’,就让ans++;如果有‘)’就让ans--,当ans<-2时即不满足题意;

如果总的ans不为0,则为奇数或‘(’‘)’个数不同,不满足题意;


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值