HDU 5831 Rikka with Parenthesis II(栈的使用)

Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 78    Accepted Submission(s): 61


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence  S , and he wants Rikka to choose two different position  i,j  and swap  Si,Sj

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
3 4 ())( 4 ()() 6 )))(((
 

Sample Output
  
  
Yes Yes No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.
 

Author
学军中学
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5831  5830  5829  5828  5827 

总结:

看到这道题不难想到以前写过的括号匹配问题,但是有一点不同的是可以通过一次改变来修正括号,遇到没思路的题不如先看一看样例,把自己解决的过程慢慢的搞清楚,也许问题就得到解决了,在手工推倒的过程中发现只要是交换位置那么一定是把前方的)和后方的(进行交换,之后又发现除去已经匹配好的括号之后最外层的括号一定是)。。(这种形式,那么我们只需要交换这两个括号就可以了
//
//  main.cpp
//  Rikka with Parenthesis II
//
//  Created by 张嘉韬 on 16/8/11.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;
const int maxn=100000+10;
int main(int argc, const char * argv[]) {
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,counter1=0,counter2=0;
        stack <char> st;
        scanf("%d",&n);
        if(n==0) {printf("Yes\n"); continue;}
        char s[maxn],left[maxn];
        for(int i=1;i<=n;i++)
        {
            cin>>s[i];
            if(s[i]=='(') counter1++;
            else counter2++;
        }

        if(counter1!=counter2) {printf("No\n"); continue;}
        if(n==2&&s[1]=='('&&s[2]==')') {printf("No\n"); continue;}
        for(int i=1;i<=n;i++)
        {
            if(s[i]=='(')
            {
                st.push(s[i]);
            }
            else
            {
                if(st.empty()==1) st.push(s[i]);
                else st.pop();
            }
        }
        if(st.empty()==1) {printf("Yes\n"); continue;}
        int p=0;
        while(st.empty()!=1)
        {
            left[++p]=st.top();
            st.pop();
        }
        left[1]='(';
        left[p]=')';
        for(int i=1;i<=p;i++)
        {
            if(left[i]=='(')
            {
                st.push(left[i]);
            }
            else
            {
                if(st.empty()==1) st.push(left[i]);
                else st.pop();
            }
        }
        if(st.empty()==1) {printf("Yes\n"); continue;}
        else {printf("No\n"); continue;}
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值