HDU 5326 Work(并查集)

Problem Description
It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
  
  
2

题意:给你n个数,每个数都有一个上级,求有几个数下级为k个;

并查集的思想,原理就是不断从下层递归,记录点数不断往上层推;

跟并查集不同的是,只是递归累加点数,不用把每个结点的上一级换成祖先;

最后遍历找满足为k的点数即可;

pre[i]表示i结点的上一个结点,manage[i]表示i结点有多少个下级;

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int pre[105];
int manage[105];
void find(int i){

	if(pre[i]==i){
		return;
	}
	else{
		manage[pre[i]]++;
		find(pre[i]);
	}
	
}  
int main(){
	int n,k;
	while(~scanf("%d %d",&n,&k)){
		memset(manage,0,sizeof(manage));
		for(int i=1;i<=n;i++)  pre[i]=i;
		for(int i=1;i<=n-1;i++){
			int a,b;
			scanf("%d %d",&a,&b);
			pre[b]=a;
		}
		for(int i=1;i<=n;i++){
			find(i);
		}
		int cnt=0;
		for(int i=1;i<=n;i++){
			if(manage[i]==k) cnt++;
		}
		printf("%d\n",cnt);
	}	
}
/*
7 2
1 2
1 3
2 4
2 5
3 6
3 7
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值