PAT (Advanced Level) Practice1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP​ programmers. Then every NG​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP​ and NG​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP​ distinct non-negative numbers Wi​ (i=0,⋯,NP​−1) where each Wi​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP​−1 (assume that the programmers are numbered from 0 to NP​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5
#include<bits/stdc++.h>
#include<cmath>
 
#define mem(a,b) memset(a,b,sizeof a);
#define INF 0x3f3f3f3f
#define MOD 1000000007
 
using namespace std;
 
typedef long long ll;
 
int rks[1100], wrr[1100], irr[1100];
 
struct node
{
    int id,val;
}nds[1100];
 
vector<node> v;
 
int cmp(node n1, node n2)
{
    return n1.val>n2.val;
}
 
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++) scanf("%d",&wrr[i]);
        for(int i=0;i<n;i++) scanf("%d",&irr[i]);
        for(int i=0;i<n;i++)
        {
            nds[i].id=irr[i];
            nds[i].val=wrr[irr[i]];
        }
 
        /*
            0 3
            3 6
            6 9
            9
        */
        queue<node> q;
        for(int i=0;i<n;i++) q.push(nds[i]);
 
        while(1)
        {
            v.clear();
            while(!q.empty()) // 筛选好下一次的比较node
            {
                v.push_back(q.front());
                q.pop();
            }
 
            if(v.size()==1) break; // 注意是1 不是0
 
            int len=v.size(), rk=len%m==0?len/m+1:len/m+2, i;
            for(i=0;i+m<=len;i+=m) // 过程筛选
            {
                sort(v.begin()+i,v.begin()+i+m,cmp);
                q.push(v[i]);
                for(int j=i+1;j<i+m;j++) rks[v[j].id]=rk;
            }
 
            if(len%m!=0) // 防止最后一次有余处理
            {
                sort(v.begin()+i,v.end(),cmp);
                q.push(v[i]);
                for(int j=i+1;j<len;j++) rks[v[j].id]=rk;
            }
 
//            for(int i=0;i<n;i++)
//                printf("%d%c",rks[i],i==n-1?'\n':' ');
        }
 
        rks[v[0].id]=1;
        for(int i=0;i<n;i++)
            printf("%d%c",rks[i],i==n-1?'\n':' ');
    }
 
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值