PAT (Advanced Level) Practice - 1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P and N​G (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi(i=0,⋯,N​P−1) where each W​i is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P−1 (assume that the programmers are numbered from 0 to N​P−1). All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

#include <stdio.h>
int main(){
    int n,m;
    scanf("%d %d",&n,&m);
    //a[i] 记录第i只老鼠的体重 b[i]记录参赛顺序 i控制小轮比赛  j控制大轮比赛  t暂存每小轮比赛的开头位置  max暂存每小轮比赛的最大体重 k暂存没小轮比赛的获胜者
    //rank 记录每大轮比赛的失败者对应的名次 即本大轮参赛组数+1
    //st[i] 记录第i只老鼠的名次  q暂存n 因为n被改变了 后面还要用  p暂存每大轮结束后 还剩下的老鼠数 并令其移动到b[]的前p个位置
    int a[n],b[n],i,j,t,rank=(n+m-1)/m+1,max,k,st[n],p,q=n;
    for(i=0;i<n;i++) scanf("%d",&a[i]);
    for(i=0;i<n;i++) scanf("%d",&b[i]);
    while(n>1){                         //剩余数量多于1只
        p=0;                            //每大轮之前 初始化p 
        for(j=0;j<rank-1;j++){          //每大轮中 有rank-1小轮 即rank-1组
            t=j*m;                      //每组的起始
            max=-1;                     //初始化最大值 任意负数都行
            k=-1;                       //初始化 用于判断该老鼠是不是该小组第一个上场比较的
            for(i=t;i<n && i<t+m;i++){  //本小组的下标范围
                if(a[b[i]]>max){        //比之前最重的还重
                    if(k!=-1) st[b[k]]=rank;    //如果这不是第一个上场的 那么之前那个最重的 就被淘汰了 赋予名次
                    max=a[b[i]];        //更新最大值 及其 下标
                    k=i;
                }
                else st[b[i]]=rank;     //没有之前最重的重 直接赋予名次
            }
            b[p++]=b[k];                //本小组优胜者 移动到b[]的前列
        }
        n=p;                            //此时p本大轮过后 全部的优胜者 进入下一大轮
        rank=(n+m-1)/m+1;               //更新名次
    }
    st[b[k]]=1;                         //全部结束 只剩最后一只了 他就是第一名
    for(i=0;i<q;i++){
        printf("%d",st[i]);
        if(i!=q-1) printf(" ");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值