02-线性结构3 Reversing Linked List (25 分)

02-线性结构3 Reversing Linked List (25 分)
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^5) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

用静态双向链表实现如下(已AC):
在这里插入图片描述

#include<stdio.h>
#include<stdlib.h>

typedef struct LNode node, *list;
struct LNode {
    int data;
    int next;
    int previous;
};
void reverse(list input, int *cur, int k) {
    if (k == 1) return;
    int before = input[*cur].previous, head = *cur;
    //头暂时跳过,放到后面处理
    *cur = input[*cur].next;
    //身
    int nextaddress, tmp;
    for (int i = 0; i < k - 2; i++, *cur = nextaddress) {
        nextaddress = input[*cur].next;
        tmp = input[*cur].previous;
        input[*cur].previous = input[*cur].next;
        input[*cur].next = tmp;
    }
    int after = input[*cur].next;//after是尾的后一个位置
    //头尾
    input[before].next = *cur;//1/6
    input[head].previous = input[head].next;//2/6
    input[head].next = input[*cur].next;//3/6
    if (after != -1)
        input[after].previous = head;//4/6
    input[*cur].next = input[*cur].previous;//5/6
    input[*cur].previous = before;//6/6
    *cur = after;
}
int main(){
    int firstaddress, n, k, cur, pre, size = 0;
    scanf("%d %d %d", &firstaddress, &n, &k);
    node input[100010];
    input[100005].next = firstaddress, input[firstaddress].previous = 100005, pre = 100005;
    for (int i = 0; i < n; i++) {
        scanf("%d", &cur);
        scanf("%d %d", &input[cur].data, &input[cur].next);
    }
    cur = firstaddress;
    for (int i = 0; i < n && cur != -1; i++, size++) {
        input[cur].previous = pre;
        pre = cur;
        cur = input[cur].next;
    }
    cur = firstaddress;
    for (int i = 0; i < size / k; i++) {
        reverse(input, &cur, k);//k>=1
    }
    cur = input[100005].next;
    for (int i = 0; i < size - 1; i++, cur = input[cur].next) {
        printf("%05d %d %05d\n", cur, input[cur].data, input[cur].next);
    }
    printf("%05d %d %d\n", cur, input[cur].data, input[cur].next);
    return 0;
}

有一些细节要注意:题目中用到了零地址,所以头结点的地址要放到后面。然后比较坑的是最后一个测试点,会给出在链表之外的结点,需要注意一下。

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值