HDU 1518 DFS

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11432    Accepted Submission(s): 3671


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 
 
 
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int s[10003]={0};
bool mark[10003]={0};
int m=0;
bool dfs(int len,int l,int count,int pos);
bool cmp(int x,int y)
{
 return x>y;
}
int main()
{
 int T=0;
 scanf("%d",&T);
 while(T--)
 {
  int sum=0;
  scanf("%d",&m);
  for(int i=0;i<m;i++)
  {
   scanf("%d",&s[i]);
   sum+=s[i];
   mark[i]=0;
  }
  if(sum%4||m<4)
  {
   printf("no\n");
   continue;
      }
  sum/=4;
  sort(s,s+m,cmp);
  if(dfs(sum,0,0,0))
  {
   printf("yes\n");
  }
  else
  {
   printf("no\n");
  }
 }
 return 0;
}
bool dfs(int len,int l,int count,int pos)
{
 if(count==4) return 1;
 for(int i=pos;i<m;i++)
 {
  if(mark[i]) continue;
  if(l+s[i]==len)
  {
   mark[i]=1;
   if(dfs(len,0,count+1,0))
    return 1;
   mark[i]=0;
  }
  else if(l+s[i]<len)
  {
   mark[i]=1;
   if(dfs(len,l+s[i],count,i+1))
    return 1;
   mark[i]=0;
  }
 }
 return 0;
}
微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码 微信小程序毕业设计期末大作业项目源码
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值