hdu 1518 square (DFS)搜索

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14066    Accepted Submission(s): 4440


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no
yes  


//这题 刚开始看的时候 简单的以为直接暴力 即可 ,求出sum 和 然后sum/4  看能不能凑成一个正方形  结果wrong
然后看数据1-20, 并且时间度5000ms   应该是搜索算法了 深度搜索
不过这个题 也着实让我cao  dan 调了一下午



/*
DFS 搜索算法 
*/

#include<iostream>
#include<string.h>

using namespace std;

int a[35];
bool vis[35];//true=1 false=0 
bool flag; //  
int n,sum;
void dfs(int bian,int s_sum,int k)
{
	//cout<<bian<<"<<"<<"  "<<"-->>"<<s_sum<<"   "<<k<<endl;
	int i;
	if(bian==5)// 从1 开始 到n的话  则结束为 n+1
	{
		flag=true;
		return;
	}
	if(s_sum==sum)	//如果  正好等于 那么 就凑下一条边  
	{
			dfs(bian+1,0,0);
			if(flag) return;	
	} 
	for( i=k;i<n;i++)
	{
//		cout<<vis[i]<<endl;
		if(vis[i]==false&&s_sum+a[i]<=sum)//没有被使用 且  凑的这条边 小于平均边 
		{
//			cout<<"******"<<endl;
			vis[i]=true;//状态变化 
			dfs(bian,s_sum+a[i],i+1);//继续往下搜索 
			if(flag) return;	
			vis[i]=false;//状态还原 
		}	
		
			if(flag) return; 
	} 
	
}
int main()
{
	int T,i;
	while(cin>>T)
	{
		while(T--)
		{
			memset(vis,0,sizeof(vis));//没进行一次 数组清零 
			int max=0; 
			sum=0;// 记录边的总和 求平均边 
			cin>>n;
			for(i=0;i<n;i++)
			{
				cin>>a[i];
				sum+=a[i];
				if(a[i]>max)//如果 里面 有 个边长度 大于 目标边 直接no 
					max=a[i];		
			} 
			if(sum%4!=0||max>(sum/4))// 要求正方形边都是整数  平均边不是 直接 no 
			{
				cout<<"no"<<endl;
				continue;
			}
			sum/=4;//求平均边 
			flag=false;//标志 
			dfs(1,0,0);
			if(flag)
				cout<<"yes"<<endl;
			else
				cout<<"no"<<endl;		
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值