itgoyo的博客

talk is cheap show me the code

Linux安装Wiznote为知笔记的方法

欢迎关注本人Github:https://github.com/itgoyo

安装 5.7.0 for Linux 64-bit (715 MB) 或者更高版本

http://download.qt.io/official_releases/qt/5.7/5.7.0/qt-opensource-linux-x64-5.7.0.run

下载下来的安装文件,更改权限为可执行,然后执行安装程序。不要用管理员权限安装,直接安装到home目录即可,例如~/Qt5.7.0

Git

sudo apt-get install git

编译工具

sudo apt-get install build-essential

CMake

sudo apt-get install cmake

zlib

sudo apt-get install zlib1g-dev

对于Mac/Linux,可以在终端中运行:

cd ~
mkdir WizTeam
cd WizTeam
git clone https://github.com/WizTeam/WizQTClient.git
cd WizQTClient
git checkout v2.4.4

详细图文教程参考这里

http://www.wiz.cn/compile-client.html

  • 通过已经编译好的版本安装

链接: https://pan.baidu.com/s/1eRK7twI 密码: 4uhn

由于Qt5和fcitx不兼容的问题,有可能导致在Wiznote里边无法正常的使用搜狗拼音

解决方法如下:

编译fcitx-qt需要cmake,安装cmake命令,如果已经安装,请略过。

sudo apt-get install cmake

安装 fcitx-libs-dev

sudo apt-get install fcitx-libs-dev

设置qmake的环境变量:

export PATH=”/home/lieefu/Qt5.5.0/5.5/gcc_64/bin”:$PATH

下载fcitx-libs源码:

git clone git@github.com:fcitx/fcitx-qt5.git

编译方法:

cd fcitx-qt5
cmake .
make
sudo make install

最后把编译得到 libfcitxplatforminputcontextplugin.so 拷贝到 Qt5.5安装目录的 Tools/QtCreator/bin/plugins/platforminputcontexts

大功告成!

CMake Error at CMakeLists.txt:8 (find_package):
  Could not find a package configuration file provided by "ECM" (requested
  version 1.4.0) with any of the following names:
    ECMConfig.cmake
    ecm-config.cmake
  Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
  to a directory containing one of the above files.  If "ECM" provides a
  separate development package or SDK, be sure it has been installed.
-- Configuring incomplete, errors occurred!

遇到上述错误处里方法:
这个页面 https://launchpad.net/ubuntu/+source/extra-cmake-modules/1.4.0-0ubuntu1 下载 extra-cmake-modules_1.4.0.orig.tar.xz
解压后:

cd extra-cmake-modules-1.4.0
cmake .
make
sudo make install

CMake Error at /home/lieefu/Qt5.5.0/5.5/gcc_64/lib/cmake/Qt5Gui/Qt5GuiConfigExtras.cmake:9 (message):
  Failed to find "GL/gl.h" in "/usr/include/libdrm".

处里方法:

sudo apt-get install libgl1-mesa-dev libglu1-mesa-dev

-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26") 
-- Could NOT find XKBCommon_XKBCommon (missing:  XKBCommon_XKBCommon_LIBRARY XKBCommon_XKBCommon_INCLUDE_DIR) 
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
  Could NOT find XKBCommon (missing: XKBCommon_LIBRARIES XKBCommon) (Required
  is at least version "0.5.0")

处里方法:

wget http://xkbcommon.org/download/libxkbcommon-0.5.0.tar.xz
tar xf libxkbcommon-0.5.0.tar.xz
./configure –prefix=/usr –disable-x11
make
sudo make install

编译libxkbcommon用到yacc,如果没有这个命令,会遇到下面的错误,yacc在 bison软件包中

sudo apt-get install bison

 YACC     src/xkbcomp/parser.c
./build-aux/ylwrap: line 176: yacc: command not found
make: *** [src/xkbcomp/parser.c] Error 127
阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。有疑问可以邮件mkosto@foxmail.com,欢迎探讨。 https://blog.csdn.net/mkosto/article/details/80348503
文章标签: Linux Wiznote
个人分类: 原创 Linux
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

Linux安装Wiznote为知笔记的方法

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭