POJ - 2411 Mondriaan's Dream 状压 寻找可行态

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 


Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

题解: 因为方块为2*1  所以  我们以两行为基准 找出可行的状态 然后枚举 各种状态即可 1 代表有   0 代表没有

1. 这个方格和上一个行的占一个方块          dfs(pos+1,up<<1,now<<1|1);
2. 这个格子空着那么就会要求上一行的有   dfs(pos+1,up<<1|1,now<<1);
3. 这个方格和下一个占一个方块                  dfs(pos+2,up<<2|3,now<<2|3);

搜索下去 , 保存可行状态,然后dp进行,dp[i][j] 表示 到第i行 以j这种状态 有多少种

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=4200000;
int n,m,len;
int p[N][2];
long long dp[12][5100];
void dfs(int pos,int up,int now)
{
	if(pos>m) return;
	if(pos==m)
	{
		p[len][0]=up;
		p[len++][1]=now;
		return;
	}
	dfs(pos+1,up<<1,now<<1|1);
	dfs(pos+1,up<<1|1,now<<1);
	dfs(pos+2,up<<2|3,now<<2|3);
}
int main()
{
	while(~scanf("%d%d",&n,&m)&&(n||m))
	{
		len=0;
		if((n*m)&1) printf("0\n");
		else
		{
			if(n>m) swap(n,m);
			dfs(0,0,0);
			memset(dp,0,sizeof(dp));
			dp[0][(1<<m)-1]=1;
			for(int i=1;i<=n;i++)
			{
				for(int j=0;j<len;j++)
				{
					dp[i][p[j][1]]+=dp[i-1][p[j][0]];
				}
			}
			printf("%lld\n",dp[n][(1<<m)-1]);
		}
	}
	return 0;
}

当然也可以枚举没两种状态,然后判断,这样就有些麻烦了

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define M0(a) memset(a,0,sizeof(a))
const int MOD=1e9+7;
const int maxn=1e4+10;
ll dp[12][1<<11];
int n,m;
int ok[1000005][2];
int len;
void init()
{
	int cnt=(1<<m)-1;
	len=0;
	//printf("%d\n",cnt);
	for(int i=0;i<=cnt;i++)
	{
		for(int j=0;j<=cnt;j++)
		{
			int flag=1;
			for(int k=0;k<m;k++)
			{
				if((i&(1<<k))==0)
				{
					if((j&(1<<k))==0)
					{
						flag=0;
						break;
					}
				}
				else
				{
					if((j&(1<<k))==0) continue;
					k++;
					if(k>=m||(i&(1<<k))==0)
					{
						flag=0;
						break;
					}
					if((j&(1<<k))==0)
					{
						flag=0;
						break;
					}
				}
			}
			if(flag)
			{
				ok[++len][0]=i;
				ok[len][1]=j;
			}	
		}
	}
 } 
int main()
{
	
	while(~scanf("%d%d",&n,&m)&&(n+m))
	{
		if(m>n) swap(n,m);
		if(n&1&&m&1)
		{
			printf("0\n");
			continue;
		}
		if(m==1)
		{
			printf("1\n");
			continue;
		}
		init();
		//printf("%d\n",len);
		memset(dp,0,sizeof(dp));
		dp[0][(1<<m)-1]=1;
		for(int i=0;i<n;i++)
			for(int j=1;j<=len;j++)
				dp[i+1][ok[j][1]]+=dp[i][ok[j][0]];
		printf("%lld\n",dp[n][(1<<m)-1]);
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值