HDU - 4722 Good Numbers 数位dp

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number. 
You are required to count the number of good numbers in the range from A to B, inclusive.

Input

The first line has a number T (T <= 10000) , indicating the number of test cases. 
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).

Output

For test case X, output "Case #X: " first, then output the number of good numbers in a single line.

Sample Input

2
1 10
1 20

Sample Output

Case #1: 0
Case #2: 1

        
  

Hint

The answer maybe very large, we recommend you to use long long instead of int.

题意:求区间[l,r]之间的数的位数和能整除10的数的个数。

题解:dp[i][j] i 表示从高位向下到第几位了,j表示当前的各位的和  算是模板题了 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long ll;
ll l,r;
int w[22],len;
ll dp[22][22];
ll dfs(int cur,int sum,int limit)
{
    if(cur==0)
    {
        return sum%10==0;
    }
    if(!limit&&dp[cur][sum]!=-1) return dp[cur][sum];
    int en=limit?w[cur]:9;
    ll ans=0;
    for(int i=0;i<=en;i++)
    {
        ans+=dfs(cur-1,(sum+i)%10,limit&&(i==en));
    }
    if(!limit) dp[cur][sum]=ans;
    return ans;
}
ll solve(ll x)
{
    if(x<0) return 0;
    len=0;
    while(x)
    {
        w[++len]=x%10;
        x/=10;
    }
    return dfs(len,0,1);
}
int main()
{
    int T;
    int nn=1;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld",&l,&r);
        printf("Case #%d: %lld\n",nn++,solve(r)-solve(l-1));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值