HDU - 4576 Robot 概率dp

 

Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise. 



At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward. 
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands. 

Input

There are multiple test cases. 
Each test case contains several lines. 
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n). 
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.   
The input end with n=0,m=0,l=0,r=0. You should not process this test case. 

Output

For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.

Sample Input

3 1 1 2
1
5 2 4 4
1
2
0 0 0 0

Sample Output

0.5000
0.2500

题目链接:题目链接

题意:1到n形成一个环,机器人从一号点出发,给定每次走的长度,方向随机,问最后在某个区域内的概率是多少。

题意:m比较大,我们可以用滚动数组解决,每次走把每个位置都更新一遍就可以了,时间比价卡

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int n,m,l,r;
double dp[210][2];
int main()
{
	while(~scanf("%d%d%d%d",&n,&m,&l,&r)&&(n+m+l+r))
	{
		int flag=0;
		int x;
		for(int i=0;i<n;i++) dp[i][0]=dp[i][1]=0;
		dp[0][0]=1;
		for(int i=1;i<=m;i++)
		{
			scanf("%d",&x);
			for(int j=0;j<n;j++)
			{
				if(dp[j][flag])
				{
					dp[(j+x)%n][flag^1]+=dp[j][flag]*0.5;
					dp[(j-x+n)%n][flag^1]+=dp[j][flag]*0.5;
					dp[j][flag]=0;  //  更新完了  清空  减少复杂度 
				}
				
			}
			flag^=1;
		}
		double ans=0;
		for(int i=l-1;i<=r-1;i++) ans+=dp[i][flag];
		printf("%.4f\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值