POJ - 2406 Power Strings next数组应用循环节

题目链接:点击查看

 

Language:Default

Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 61784 Accepted: 25534

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题意:给出一个字符串 问它最多由多少相同的子串组成 

题解:判断是否全部由循环子串构成即可 即判断  len % ( len - nex[len] ) 是否为0

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=1e6+10;
char s[N];
int nex[N],len;
void getnex()
{
	int i=0,j=-1;
	nex[0]=-1;
	while(i<len)
	{
		if(j==-1||s[i]==s[j]) nex[++i]=++j;
		else j=nex[j];
	}
}
int main()
{
	while(~scanf("%s",s)&&s[0]!='.')
	{
		len=strlen(s);
		getnex();
		if(len%(len-nex[len])) printf("%d\n",1);
		else printf("%d\n",len/(len-nex[len]));
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值