HDU - 5918 Sequence I

Mr. Frog has two sequences a1,a2,⋯,ana1,a2,⋯,an and b1,b2,⋯,bmb1,b2,⋯,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,⋯,bmb1,b2,⋯,bm is exactly the sequence aq,aq+p,aq+2p,⋯,aq+(m−1)paq,aq+p,aq+2p,⋯,aq+(m−1)p where q+(m−1)p≤nq+(m−1)p≤n and q≥1q≥1.

Input

The first line contains only one integer T≤100T≤100, which indicates the number of test cases. 

Each test case contains three lines. 

The first line contains three space-separated integers 1≤n≤106,1≤m≤1061≤n≤106,1≤m≤106 and 1≤p≤1061≤p≤106. 

The second line contains n integers a1,a2,⋯,an(1≤ai≤109)a1,a2,⋯,an(1≤ai≤109). 

the third line contains m integers b1,b2,⋯,bm(1≤bi≤109)b1,b2,⋯,bm(1≤bi≤109).

Output

For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.

Sample Input

2
6 3 1
1 2 3 1 2 3
1 2 3
6 3 2
1 3 2 2 3 1
1 2 3

Sample Output

Case #1: 2
Case #2: 1

题解:先把在一组的存起来,在kmp求

数据比较水 这个题暴力也能过

kmp详细介绍:https://blog.csdn.net/starstar1992/article/details/54913261/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
const int maxn=1e6+10;
int n,m,p;
int a[maxn],b[maxn];
string s1[maxn],s2;
int nex[maxn];
void getnex()
{
    memset(nex,-1,sizeof(nex));
    int k=-1,j=0;
    while(j<m)
    {
        if(k==-1||s2[j]==s2[k])
        {
            j++,k++;
            nex[j]=k;
        }
        else k=nex[k];
    }

}
int solve(int k)
{
    int i=0,j=0;
    int l=s1[k].size();
    int ans=0;
    while(i<l&&j<m)
    {
        if(j==-1||s1[k][i]==s2[j])
        {
            i++,j++;
        }
        else
        {
            j=nex[j];
        }

        if(j==m)
        {
            ans++;
            j=nex[j];
        }
    }
    return ans;
}
int main()
{
    int t;
    cin>>t;
    int nn=1;
    while(t--)
    {
        cin>>n>>m>>p;
        for(int i=1;i<=p;i++) s1[i].clear();
        s2.clear();
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(i%p==0)
            {
                s1[p]+=(char)(a[i]+'0');
            }
            else s1[i%p]+=(char)(a[i]+'0');
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&b[i]);
            s2+=(char)(b[i]+'0');
        }
        printf("Case #%d: ",nn++);
        ll ans=0;
        getnex();
        for(int i=1;i<=p;i++)
        {
            ans+=solve(i);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值