HDOJ 4324 Triangle LOVE (拓扑排序)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3692    Accepted Submission(s): 1455


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 
Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 
Sample Output
  
  
Case #1: Yes Case #2: No
 


 

//对于矩阵来说,第i行第j列是1时,表示i喜欢j,给你一个爱情关系矩阵,判断是否存在三角恋,或者是多角恋,偷笑爱情啊,真让人捉摸不透

 

 

#include<cstdio>
#include<cstring>
char map[2005][2005];
int times[2005];
int t=1;
void topo(int n)
{
    int i,j,top;
    for (i=0;i<n;i++)
    {
        top=-1;
        for (j=0;j<n;j++)
        {
            if (times[j]==0)
            {
                top=j;
                times[j]--;
                break;
            }
        }
        if (top==-1)
        break;
        for (j=0;j<n;j++)
        {
            if (map[top][j]=='1')
            {
                times[j]--;
                map[top][j]='0';
            }
        }
    }
    printf ("Case #%d:",t++);
    if (i<n)
    printf (" Yes\n");
    else
    printf (" No\n");
}
int main()
{
    int k,m,n,i,j;
    scanf ("%d",&k);
    while (k--)
    {
        scanf ("%d",&n);
        memset(times,0,sizeof(times));
        for (i=0;i<n;i++)
        {
            scanf ("%s",map[i]);
            for (j=0;j<n;j++)
            {
                if (map[i][j]=='1')
                times[j]++;
            }
        }
        topo(n);
    }
    return 0;
}


 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值