pat甲级 1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

题目大意:给两个不包含零项的两个多项式,计算两个多项式的乘积。

样例解析:第一个多项式:y1 = 2.4x + 3.2。第二个y2 = 1.5x² + 0.5x

     乘积:y = y1 * y2 = 3.6x³ + 6.0x² + 1.6x

坑点:1、两个多项式乘积为0的项不显示。2、乘积多项式的最大指数为2000


#include <cstdio>
#include <cstdlib>
#include <climits>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const int MAXN = 10 + 5;
const int INF = 0x7f7f7f7f;
template <class XSD> inline XSD f_min(XSD a, XSD b) { if (a > b) a = b; return a; }
template <class XSD> inline XSD f_max(XSD a, XSD b) { if (a < b) a = b; return a; }

struct NODE{
    int ni;
    double ai;
}A[15], B[15];

int main(){
    int n, m;
    double ans[2005];
    while(~scanf("%d", &n)){
        memset(ans, 0, sizeof ans);
        for(int i=0; i<n; i++){
            scanf("%d%lf", &A[i].ni, &A[i].ai);
        }
        scanf("%d", &m);
        for(int i=0; i<m; i++){
            scanf("%d%lf", &B[i].ni, &B[i].ai);
        }
        int cnt=0;
        for(int i=0; i<n; i++){
            for(int j=0; j<m; j++){
                int x = A[i].ni + B[j].ni;
                ans[x] += A[i].ai * B[j].ai;
            }
        }
        for(int i=0; i<=2000; i++) if(ans[i]!=0) cnt++;
        printf("%d", cnt);
        for(int i=2000; i>=0; i--){
            if(ans[i]!=0) printf(" %d %.1f", i, ans[i]);
        }
        printf("\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值