1118 Birds in Forest (25分)

1118 Birds in Forest (25分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

 题⽬目⼤大意:⼀一幅画⾥里里⾯面的⻦鸟为同⼀一棵树上的,问有多少棵树和多少只⻦鸟,以及对于两只⻦鸟判断是否在 同⼀一个树上~
分析:使⽤用并查集就可以啦~将⼀一幅画中⻦鸟使⽤用Union函数合并在同⼀一个集合⾥里里⾯面,cnt[i]数组保存以i为 FindFather结点的集合⾥里里⾯面的⻦鸟的个数,exist[i]表示⻦鸟的id——i在输⼊入的⻦鸟的序号⾥里里⾯面是否出现过,遍 历cnt数组并累加所有不不为0的个数即可得知有多少棵树,累加所有出现过的⻦鸟的id的cnt的值即可得知 ⻦鸟的个数~判断两只⻦鸟是否在同⼀一棵树,只需要知道这两只⻦鸟的findFather是否相等即可

#include<bits/stdc++.h>
using namespace std;
int n,m,k;
const int maxn=10010;
int fa[maxn]= {0},cnt[maxn]= {0};
int findFather(int x)
{
    int a=x;
    while(x!=fa[x])
        x=fa[x];
    while(a!=fa[a])
    {
        int z=a;
        a=fa[a];
        fa[z]=x;
    }
    return x;
}
void Union(int a,int b)
{
    int fa1=findFather(a);
    int fb=findFather(b);
    if(fa1!=fb)fa[fa1]=fb;
}
bool exist[maxn];
int main()
{
    scanf("%d",&n);
    for(int i=1; i<=maxn; i++)
        fa[i]=i;
    int id,temp;
    for(int i=0; i<n; i++)
    {
        scanf("%d%d",&k,&id);
        exist[id]=true;
        for(int j=0; j<k-1; j++)
        {
            scanf("%d",&temp);
            Union(id,temp);
            exist[temp]=true;
        }
    }
    for(int i=1; i<=maxn; i++)
    {
        if(exist[i]==true)
        {
            int root=findFather(i);
            cnt[root]++;
        }
    }
    int numTrees=0,numBirds=0;
    for(int i=1; i<=maxn; i++)
    {
        if(exist[i]==true&&cnt[i]!=0)
        {
            numTrees++;
            numBirds+=cnt[i];
        }
    }
    printf("%d %d\n",numTrees,numBirds);
    scanf("%d",&m);
    int ida,idb
    ;
    for(int i=0; i<m; i++)
    {
        scanf("%d%d",&ida,&idb);
        printf("%s\n",(findFather(ida)==(findFather(idb))?"Yes":"No"));
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值