PAT甲级 1107. Social Clusters (30)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] ... hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1


题目大意

n(<=1000)个人都有自己喜欢的k[0,1000]个喜好,有共同喜好的人为一组。

问你共有几组,并且按从大到小的顺序输出每组的人数。

题目解析

考并查集的一道题,根据每个人的喜好更新并查集。

更新完后,搜一遍(1-n)每个人的最顶级祖先的个数就可以了。

#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cstdlib>
#include <climits>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define ll long long
const int MAXN = 1000 + 5;
const int MAXM = 100000 + 5;
const int INF = 0x7f7f7f7f;
template <class XSD> inline XSD f_min(XSD a, XSD b) { if (a > b) a = b; return a; }
template <class XSD> inline XSD f_max(XSD a, XSD b) { if (a < b) a = b; return a; }
bool cmp(int x, int y){return x>y;}
int n, m;
int fa[MAXN];
int Get_fa(int x){return x==fa[x]?x:fa[x]=Get_fa(fa[x]);}
void Union(int x, int y){
    int X=Get_fa(x), Y=Get_fa(y);
    if(X!=Y) fa[X]=fa[Y];
}
int x[MAXN], y;
void Getdata(){
    int k, cnt=0;
    char c;
    for(int i=0; i<MAXN; i++) fa[i]=i;
    for(int i=0; i<n; i++){
        scanf("%d%c", &k, &c);
        scanf("%d", &x[i]);
        for(int j=1; j<k; j++){
            scanf("%d", &y);
            Union(x[i], y);
        }
    }
}
int sets[MAXN];
void Solve(){
    memset(sets, 0, sizeof sets);
    for(int i=0; i<n; i++){
        int father=Get_fa(x[i]);
        sets[father]++;
    }
    int ans[MAXN], cnt=0;
    for(int i=0; i<MAXN; i++) if(sets[i]) ans[cnt++]=sets[i];
    sort(ans, ans+cnt, cmp);
    printf("%d\n", cnt);
    for(int i=0; i<cnt; i++) printf("%d%c", ans[i], i==(cnt-1)?'\n':' ');
}
int main(){
    while(~scanf("%d", &n)){
        Getdata();
        Solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值