1138 Postorder Traversal (25 分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.
Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
Sample Output:
3
题意 :给出 二叉树的结点数目,以及其前序和中序遍历序列,输出后序遍历的第一个节点
25分的题我只得了22分,系统提示运行超时~~~~~
#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int pre[50001],in[50001];
int getPost(int prel,int prer,int inl,int inr){
int root=pre[prel];
if(prel==prer)
return pre[prel];
int i;
for(i=inl;i<=inr;i++){
if(root==in[i])
break;
}
int len=i-inl;//左子树中节点的个数
if(i==inl){
//没有左子树
return getPost(prel+len+1,prer,i+1,inr);
}
else{
//有左子树
return getPost(prel+1,prel+len,inl,i-1);
}
}
int main()
{
int n,i,k;
cin>>n;
for(i=0;i<n;i+