PAT.A1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p~1~\^k~1~ * p~2~\^k~2~ *…*p~m~\^k~m~.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p~1~\^k~1~ * p~2~\^k~2~ *…*p~m~\^k~m~, where p~i~'s are prime factors of N in increasing order, and the exponent k~i~ is the number of p~i~ -- hence when there is only one p~i~, k~i~ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int maxn = 100010;
bool p[maxn] = { 0 };
int prime[maxn], pnum = 0;
void Find_prime() {
	for (int i = 2; i < maxn; i++) {
		if (p[i] == false) {
			prime[pnum++] = i;
			for (int j = i + i; j < maxn; j += i) {
				p[j] = true;
			}
		}
	}
}
struct factor {
	int x, cnt;
}fac[10];
int main() {
	Find_prime();
	//for (int i = 0; i < pnum; i++)
	//	printf("%d ", prime[i]);
	int n,num = 0;;
	scanf("%d", &n);
	printf("%d=", n);
	if (n == 1) {
		printf("1");
		return 0;
	}
	for (int i = 0; i < maxn;i++) {
		if (n%prime[i] == 0) {
			fac[num].x = prime[i];
			fac[num].cnt = 0;
			while (n%prime[i] == 0) {
				fac[num].cnt++;
				n /= prime[i];
			}
			num++;
		}
		if (n == 1) break;
	}
	if (n != 1) {
		fac[num].x = n;
		fac[num++].cnt = 1;
	}
	//for (int i = 0; i < num; i++) {
	//	printf("%d %d\n", fac[i].x, fac[i].cnt);
	//}
	for (int i = 0; i < num; i++) {
		printf("%d", fac[i].x);
		if (fac[i].cnt > 1) {
			printf("^%d",fac[i].cnt); 
		}
		if(i<num-1) printf("*");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值