POJ 3126 Prime Path

来自<http://poj.org/problem?id=3126>

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25025 Accepted: 13799

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source


题意:给出两个四位的质数,a,b,要从a变成b,每次可更改一位数字上的数,且每次的更改后仍为质数,问最少的更改次数

题解:bfs。可以记录这个数上一次更改的位置,这一次这个数同样的位置不需要遍历。

#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
typedef long long LL;
int pr[10005],vis[10005];
int n,a,b;
bool check(int x){
    if(x==2||x==3) return true;
    for(int i=3;i*i<=x;i+=2)
        if(x%i==0) return false;
    return true;
}
struct Node{
    int x,cost,i;
    Node(int x=0,int cost=0,int i=0):x(x),cost(cost),i(i){}
};
int de(int times,int x){
    int re=x;
    re/=times;re*=times;
    re+=x%(times/10);
    return re;
}
int bfs(int x){
    queue<Node>q;
    q.push(Node(x,0,0));
    vis[x]=1;
    while(!q.empty()){
        Node t=q.front();
        q.pop();
        if(t.x==b) return t.cost;
        int dx,tmp,times;
        for(int i=1;i<=4;i++){
            times=1;
            if(i==t.i) continue;
        	for(int j=1;j<=i;j++) times*=10;
            dx=de(times,t.x);
            for(int j=0;j<=9;j++){
            	tmp=dx+times/10*j;
                if((i==4&&j==0)||vis[tmp]||!pr[tmp]) continue;
                q.push(Node(tmp,t.cost+1,i));
                vis[tmp]=1;
            }
        }
    }
    return -1;
}
int main(){
    for(int i=2;i<10000;i++) pr[i]=1;
    for(int i=2;i<10000;i++){
        if(pr[i]){
            if(check(pr[i]))
                for(int j=2;i*j<10000;j++)
                    pr[i*j]=0;
            else pr[i]=0;
        }
    }
    cin>>n;
    while(n--){
        memset(vis,0,sizeof(vis));
        cin>>a>>b;
        int ans=bfs(a);
        if(ans>=0) printf("%d\n",ans);
        else printf("Impossible\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值