HDU1595 find the longest of the shortest

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1595


find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3310    Accepted Submission(s): 1225


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
 
 
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
 
 
11 13 27

O(N²)的Dijkstra算法。在第一次用Dijkstra算法时记录到达每个节点的最短路上的前一个节点,这样就可以找出最短路径。

枚举每一条边,依次删除后跑Dijkstra,这样就可求出最长最短路。


代码:

#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int inf=1e9;
int g[1001][1010];
int dis[1001];
bool vis[1001];
int p[1001];
int n,m;
void dijkstra()
{
	for(int i=2;i<=n;i++)dis[i]=inf;
	dis[1]=0;
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	{
		int mark=-1,tot=inf;
		for(int j=1;j<=n;j++)
		{
			if(vis[j]==0)
			{
				if(tot>dis[j])
				{
					tot=dis[j];
					mark=j;
				}
			}
		}
		vis[mark]=1;
		for(int j=1;j<=n;j++)
		{
			dis[j]=min(dis[j],dis[mark]+g[mark][j]);
		}
	}
}
int main()
{
	ios::sync_with_stdio(false);
	while(cin>>n>>m)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				g[i][j]=i==j?0:inf;
			}
		}
		for(int i=1;i<=m;i++)
		{
			int a,b,v;
			cin>>a>>b>>v;
			g[a][b]=g[b][a]=min(g[a][b],v);
		}
		for(int i=2;i<=n;i++)dis[i]=inf;
		dis[1]=0;
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=n;i++)
		{
			int mark=-1,tot=inf;
			for(int j=1;j<=n;j++)
			{
				if(vis[j]==0)
				{
					if(tot>dis[j])
					{
						tot=dis[j];
						mark=j;
					}
				}
			}
			vis[mark]=1;
			for(int j=1;j<=n;j++)
			{
				if(dis[j]>dis[mark]+g[mark][j])
				{
					p[j]=mark;
					dis[j]=dis[mark]+g[mark][j];
				}
			}
		}
		int tot=0;
		for(int i=n;i!=1;i=p[i])
		{
			int t=g[i][p[i]];
			g[i][p[i]]=g[p[i]][i]=inf;
			dijkstra();
			g[i][p[i]]=g[p[i]][i]=t;
			if(dis[n]!=inf)tot=max(tot,dis[n]);
		}
		cout<<tot<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值