Frogger
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 43382 | Accepted: 13836 |
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2 0 0 3 4 3 17 4 19 4 18 5 0
Sample Output
Scenario #1 Frog Distance = 5.000 Scenario #2 Frog Distance = 1.414
Source
比赛的时候没有看懂题的意思就按测试数据写了代码,结果不出意外的wa了
题意:给你n块石头的坐标,有两只青蛙分别在一号石头和二号石头上。一号青蛙想去找二号青蛙,求他所走的最短路上的最大跳跃距离是多少。
最小生成树。Prim和Kruskal都可以。
最小生成树。Prim和Kruskal都可以。
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<math.h>
using namespace std;
const int MAXN =210;
const int MAXM =40040;
const int INF = 0x7fffffff;
struct EdgeNode
{
int x;
int y;
double len;
}q[MAXM];
int father[MAXM],b=1,n,cnt;
double X[MAXN],Y[MAXN];
int find(int x)//确认点所在的集合
{
if(x != father[x])
father[x] = find(father[x]);
return father[x];
}
int cmp(EdgeNode a,EdgeNode b)
{
return a.len < b.len;//按距离从小到大排序
}
double getlen(int a,int b)
{
return sqrt((X[a]-X[b])*(X[a]-X[b])+(Y[a]-Y[b])*(Y[a]-Y[b]));
}
void Kruskal()
{
double ans=INF;
sort(q,q+cnt,cmp);
for(int i = 0; i < cnt; ++i)
{
int u = find(q[i].x);
int v = find(q[i].y);
if(u!=v)//判断两块石头是否同属一个集合
{
father[v] = u;
if(find(0)==find(1))
{
ans=q[i].len;
break;
}
}
}
printf("%.3lf\n\n",ans);
}
int main()
{
while(~scanf("%d",&n),n!=0)
{
cnt=0;
printf("Scenario #%d\n",b++);
printf("Frog Distance = ");
for(int i=0; i<MAXM; i++)
father[i]=i;
memset(X,0,sizeof(X));
memset(Y,0,sizeof(Y));
for(int i=0; i<n; i++)
scanf("%lf %lf",&X[i],&Y[i]);
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
{
if(i==j)
continue;
q[cnt].x=i;
q[cnt].y=j;
q[cnt].len=getlen(i,j);
cnt++;
}
Kruskal();
}
return 0;
}