POJ 3734 (快速幂)

Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5182 Accepted: 2409

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

Source


题意是红蓝绿黄四种颜色涂n块,最终红绿块数是偶数的方案数。

很容易想到一个DP式子DP[i][0][0]表示共i块砖,后面两维的0(1)表示红色(绿色)为偶数(奇数),然后转移方程很简单,写成矩阵的形式就是


然后用一个快速幂。

#include <iostream>
#include <cmath>
#include <cstdlib>
#include <time.h>
#include <vector>
#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;
#define maxn 4111
#define mod 10007

int t, n;
struct m {
	int a[4][4];
	m operator * (const m &aa) const {
		m ans;
		memset (ans.a, 0, sizeof ans.a);
		for (int i = 0; i < 4; i++) {
			for (int j = 0; j < 4; j++) {
				for (int k = 0; k < 4; k++) {
					ans.a[i][j] += a[i][k]*aa.a[k][j]%mod;
					ans.a[i][j] %= mod;
				}
			}
		}
		return ans;
	}
	void show () {
		for (int i = 0; i < 4; i++) {
			for (int j = 0; j < 4; j++)
				cout << a[i][j] << " ";
			cout << endl;
		}
	}
};

m qpow (m a, int b) {
	if (b == 1)
		return a;
	m ans = qpow (a, b>>1);
	ans = ans*ans;
	if (b&1)
		ans = ans*a;
	return ans;
}

int solve (int n) {
	int a[4][4] = {{2, 1, 1, 0},{1, 2, 0, 1},{1, 0, 2, 1},{0, 1, 1, 2}};
	m aa; 
	for (int i = 0; i < 4; i++) {
		for (int j = 0; j < 4; j++)
			aa.a[i][j] = a[i][j];
	}
	aa = qpow (aa, n);
	//aa.show ();
	return aa.a[0][0]%mod;
}

int main () {
	scanf ("%d", &t);
	while (t--) {
		scanf ("%d", &n);
		printf ("%d\n", solve (n));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值