poj3734——矩阵快速幂入门题

传送门:http://poj.org/problem?id=3734

Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7111 Accepted: 3443

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

Source


这道题是在《挑战》里面看到的一道题思路开始是真没想到,理解思路之后自己推出了矩阵,感觉更加理解了矩阵构造(还只是简单的矩阵。。。)

思路:通过题目中逻辑关系推出递推式。根据题目中的“红块和绿块的数量和都是偶数”分析得出递推式。为了满足题意就有了三种关系:1、红绿都是偶数2、红绿有一种

3、红绿都是奇数

在这里设ai表示从0到i红块和绿块数量都是偶数,bi表示从0到i红块或者绿块有一种的数量是偶数,ci表示从0到i红块和绿块数量都是奇数

第i+1块的颜色是受第i块的影响的。为了在第i+1块满足题意就有了这三种情况对应的表达式:

ai+1 = 2ai + bi

bi+1 = 2ai + 2bi + 2ci

ci+1 = 2ci + bi

由此可以构造出矩阵

2 1 0

2 2 2

0 1 2

主要是构造矩阵,之后的可以套模板了

代码:

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn 5
#define cl(a,b) memset(a,b,sizeof(a))
const int mod = 10007;
using namespace std;
typedef long long ll;
int n, x;
struct matrix{
    ll a[maxn][maxn];
};
matrix multi(matrix x,matrix y){
    int i,j,k;
    matrix tmp;
    cl(tmp.a, 0);
    for (i=1;i<=n;i++){
        for (j=1;j<=n;j++)
        {
            if (!x.a[i][j]) continue;
            for (k=1;k<=n;k++)
            {
                tmp.a[i][k]+=x.a[i][j]*y.a[j][k];
                tmp.a[i][k]%=mod;
            }
        }
    }
    return tmp;
}
matrix power(matrix s,int p){
    int i;
    matrix res;
    cl(res.a, 0);
    for(i=1;i<=n;i++) res.a[i][i]=1;
    while (p){
        if (p&1) res=multi(res,s);
        p>>=1;
        s=multi(s,s);
    }
    return res;
}
int main(){
    int t;
    n = 3;
    matrix m;
    cl(m.a, 0);
	m.a[1][1] = 2;m.a[1][2] = 1;m.a[1][3] = 0;
	m.a[2][1] = 2;m.a[2][2] = 2;m.a[2][3] = 2;
    m.a[3][1] = 0;m.a[3][2] = 1;m.a[3][3] = 2;
    scanf("%d",&t);
    while (t--){
        scanf("%d",&x);
        matrix ans=power(m,x);
       /* cout<<"**************"<<endl;
        for(int i = 1; i <= 3; i++){
            for(int j = 1; j <= 3; j++)
                printf("%d ",ans.a[i][j]);
            printf("\n");
        }
        cout<<"**************"<<endl;*/
        printf("%d\n",ans.a[1][1]);
    }
    return 0;
}

ps:尝试了vector的写法,相对比较简洁但是更加耗时。之前的kij优化方法没有直接跳出快,这道题直接跳出空值的优化可以达到0MS(可能是题目的数据问题)

这题适合理解矩阵的构造,但是用其他方法可能更好一点(一般也不会直接想到用矩阵来解吧,,,),比如母函数就是一种。组合数学很强大的,可惜自己数学不强

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵序列问的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值