HDU 3652 (数位DP 水~)

Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2
 

dfs的时候需要继续前一位是不是1,有没有出现13,这一位是不是9.

#include <bits/stdc++.h>
using namespace std;

long long n;
int bit[22], cnt;
long long dp[22][22][2][2];

long long dfs (int pos, int m1, bool f1, bool f2, bool f3) {
    //位 余数 前一位是不是1 能不能取到9 有没有出现13
    if (pos == 0) {
        return (m1 == 0 && f3);
    }
    if (f2 && dp[pos][m1][f1][f3] != -1) {
        return dp[pos][m1][f1][f3];
    }
    int Max = (f2 ? 9 : bit[pos]);
    long long ans = 0;
    for (int i = 0; i <= Max; i++) {
        ans += dfs (pos-1, (m1*10+i)%13, i == 1, f2||(i<Max), f3||(f1&&(i==3)));
    }
    if (f2)
        dp[pos][m1][f1][f3] = ans;
    return ans;
}

long long f (long long num) {
    cnt = 0;
    while (num) {
        bit[++cnt] = num%10;
        num /= 10;
    }
    return dfs (cnt, 0, 0, 0, 0);
}

int main () {
    memset (dp, -1, sizeof dp);
    while (cin >> n) {
        cout << f (n) << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值