hdu 1024 最大M子段和 Max Sum Plus Plus(dp)(中等难度)

hdu 1024 最大M子段和 转载▼
Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4521 Accepted Submission(s): 1476

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.

Author
JGShining(极光炫影)

思路:
dp[i][j]表示前j个元素分成i段的最优解,同时这个最优解是由a[j]元素结束的。
转移方程是dp[i][j]=max{f[i][j-1]+a[j],f[i-1][k]+a[j],(i-1<=k

#include <stdio.h>
__int64 dp[2][1000001];
__int64 a[1000001];
__int64 b[1000001];
__int64 res;
int n,m;
__int64 Max(__int64 x,__int64 y)
{
    if(x>y)return x;
    else   return y;
}
int main()
{

//    freopen("a.txt","r",stdin);
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        int t=1;
        res=0;
        int i,j,k;
        for(i=1;i<=n;i++){b[i]=0;dp[0][i]=dp[1][i]=0;scanf("%I64d",&a[i]);}
        for(i=1;i<=m;i++)
        {
            dp[t][i]=dp[1-t][i-1]+a[i];
            __int64 max=dp[1-t][i-1];
            for(j=i+1;j<=n-m+i;j++)
            {
                max=Max(max,dp[1-t][j-1]);
                dp[t][j]=Max(dp[t][j-1],max)+a[j];
            }
            t=1-t;
        }
        t=1-t;
        res=-1111111111111;
        for(j=m;j<=n;j++)if(res<dp[t][j])res=dp[t][j];
        printf("%I64d\n",res);
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值