【POJ3368】Frequent values(RMQ)

Description

You are given a sequence of n integers a1 , a2 , … , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , … , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , … , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, …, n}) separated by spaces. You can assume that for each i ∈ {1, …, n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

题目大意:给出一个非降数列,多次求[l,r]内众数的出现次数。
题解:RMQ,水一发玩玩。每个位置记这个数字到现在为止出现了几次,询问时用RMQ查,两边不全的特判一下就好了。

代码如下:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#define ll long long
#define inf 0x7f7f7f7f
#define N 100005
using namespace std;
int n,m,a[N],f[N],g[N][20],s,t; 
void init()
{
    for(int i=1;i<=n;i++) g[i][0]=f[i];
    for(int j=1;(1<<j)<=n;j++)
    for(int i=1;i-1+(1<<j)<=n;i++) g[i][j]=max(g[i][j-1],g[i+(1<<j>>1)][j-1]);
} 
int rmq(int l,int r)
{
    if(l>r) return 0;
    int k=log2(r-l+1);
    return max(g[l][k],g[r-(1<<k)+1][k]);
}
int main()
{
    while(~scanf("%d",&n) && n)
    {
        scanf("%d",&m);
        a[0]=inf;
        for(int i=1;i<=n;i++) 
        {
            scanf("%d",&a[i]);
            if(a[i]==a[i-1]) f[i]=f[i-1]+1;
            else f[i]=1;
        }
        init();
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&s,&t);
            int tmp=s;
            while(tmp<=t && a[tmp]==a[tmp-1]) tmp++;
            printf("%d\n",max(tmp-s,rmq(tmp,t)));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值