远程服务器提示出现身份验证错误,要求的函数不受支持,这可能是由于credssp加密oracle修正,无法远程,解决办法

远程服务器提示出现身份验证错误,要求的函数不受支持,这可能是由于credssp加密oracle修正,无法远程,解决办法
网上也找了很多办法

网上主要有以下几种方法,但是都不行。

1.如果可以直接访问,则只需在主机上通过安装对应的Windows 补丁即可解决

2.对于无法进行直接访问的,可以通过打开组策略(gpedit.msc),找到如下策略:

策略路径:“计算机配置”->“管理模板”->“系统”->“凭据分配”

英文版策略路径名称:“Computer Configuration”-> "Administrative Templates" -> "System" -> "Credentials Delegation"

设置名称: 加密 Oracle 修正 (Encryption Oracle Remediation)

默认为未配置,我们只需要将其改为已启用,防护级别改为“易受攻击”,应用并保存即可正常连接

ps:在Windows Server 2012 R2中已看不到此选项,建议尝试更新系统后再尝试,或也可尝试通过导入以下注册表尝试解决,如果仍旧无法解决,建议暂时通过修改系统属性中远程桌面的安全选项以解决连接问题

注册表路径HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters
AllowEncryptionOracle
数据类型DWORD
是否需要重启?

 

 

 

运行regedit打开注册表管理器。

 

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\

 

创建两级文件夹,也就是新建项。CredSSP\Parameters

 

然后再Parameters下新建DWORD 32位,修改名称AllowEncryptionOracle。

 

双击修改值为2.



上面的办法都试了,要不是找不到,要不是不行,后来详细看了一下,发现了一个问题,打开远程设置,把‘仅允许使用网络级别身份验证的远程桌面的计算机连接’不勾选就可以远程了。


已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页