HDU4763-Theme Section(KMP+二分)

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1098    Accepted Submission(s): 570


Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
  
  
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
  
  
0 0 1 1 2
 
题意:输出最长的前缀, 前缀要满足在原串中至少匹配3次

思路: 二分前缀的结尾点,右边为3分之一原串,用KMP 统计出现次数,即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int  maxn = 1000000+10;
int next[maxn],n;
char str[maxn];

void getNext(){
    next[0] = next[1] = 0;
    for(int i = 1,j; i < n; i++){
        j = next[i];
        while(j && str[i] != str[j]) j = next[j];
        if(str[i] == str[j]) next[i+1] = j+1;
        else next[i+1] = 0;
    }
}

bool find(int ed){
    int cnt = 0;
    for(int i = 0,j = 0; i < n; i++){
        while(j && str[i] != str[j]) j = next[j];
        if(str[i]==str[j]) j++;
        if(j==ed){
            ++cnt;
            j = 0;
            if(cnt>=3) return true;
        }
    }
    return false;
}

int binary_search(){
    int L = 1,R = n/3+1,mid;
    while(L <= R){
        mid = (L+R)>>1;
        if(find(mid)){
            L = mid+1;
        }else{
            R = mid-1;
        }
    }
    if(find(L)) return L;
    else if(find(R)) return R;
    else return  L-1;

}

int main(){

    int ncase;
    cin >>  ncase;
    while(ncase--){
        scanf("%s",str);
        n = strlen(str);
        getNext();
        printf("%d\n",binary_search());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值