UVa1635 - Irrelevant Elements(质因数分解)

Young cryptoanalyst Georgie is investigating different schemes of generating random integer numbers ranging from  0  to  m - 1 . He thinks that standard random number generators are not good enough, so he has invented his own scheme that is intended to bring more randomness into the generated numbers. First, Georgie chooses  n  and generates  n  random integer numbers ranging from  0  to  m - 1 . Let the numbers generated be  a1a2,..., an . After that Georgie calculates the sums of all pairs of adjacent numbers, and replaces the initial array with the array of sums, thus getting  n - 1  numbers:    a1 + a2a2 + a3,..., an - 1 + an . Then he applies the same procedure to the new array, getting  n - 2  numbers. The procedure is repeated until only one number is left. This number is then taken modulo  m . That gives the result of the generating procedure. Georgie has proudly presented this scheme to his computer science teacher, but was pointed out that the scheme has many drawbacks. One important drawback is the fact that the result of the procedure sometimes does not even depend on some of the initially generated numbers. For example, if  n = 3  and  m = 2 , then the result does not depend on  a2 . Now Georgie wants to investigate this phenomenon. He calls the  i -th element of the initial array  irrelevant  if the result of the generating procedure does not depend on  ai . He considers various  n  and  m  and wonders which elements are irrelevant for these parameters. Help him to find it out.

Input 

Input file contains several datasets. Each datasets has  n  and  m  (   1$ \le$n$ \le$100 000 2$ \le$m$ \le$109 ) in a single line.

Output 

On the first line of the output for each dataset print the number of irrelevant elements of the initial array for given  n  and  m . On the second line print all such  i that  i -th element is irrelevant. Numbers on the second line must be printed in the ascending order and must be separated by spaces.

Sample Input 

3 2

Sample Output 

1
2

题意:整个式子的和可以  化简为  sigma (C(n-1,i-1)*ai)

思路:只要判断C(n-1,i-1)能否被 m整除即可。

做法是先分解m的质因数,然后计算1!~(n-1)!  包含m的质因数的个数

C(n-1,i-1) = (n-1)!/((i-1)!*(n-i)!) 

只要判断 剩下的质因数的个数是否大于等于m的任一个质因数的个数即可


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
typedef long long LL;
const int maxp = 40000+10;
const int maxn = 100000+10;
int n,m;
bool isPrime[maxp];
vector<int> ret,prime,hp,cnt,tmp;
vector<int> g[maxn];
void getPrime(){
    memset(isPrime,true,sizeof isPrime);
    for(int i = 2; i < maxp; i++){
        if(isPrime[i]){
            prime.push_back(i);
            for(int j = i+i;j < maxp; j += i){
                isPrime[j] = false;
            }
        }
    }
}
void getDigit(){
    int tk = m;
    for(int i = 0; i < prime.size() && prime[i]*prime[i] <= tk; i++){
        if(tk%prime[i]==0){
            int k = 0;
            hp.push_back(prime[i]);
            while(tk%prime[i]==0){
                tk /= prime[i];
                k++;
            }
            cnt.push_back(k);
        }
    }
    if(tk>1){
        hp.push_back(tk);
        cnt.push_back(1);
    }
}
void init(){
    cnt.clear();
    hp.clear();
    ret.clear();
    getDigit();
    for(int i = 0; i <= n-1; i++) g[i].clear();
    for(int i = 0; i <= n-1; i++) {
        for(int j = 0; j < hp.size(); j++){
            int d = 0,t = i;
            while(t) {
                d += t/hp[j];
                t /= hp[j];
            }
            g[i].push_back(d);
        }
    }
}
void solve(){
	bool miden = false;
    for(int i = 2; i <= (n-1)/2+1; i++){
        bool flag = true;
        for(int j = 0; j < hp.size(); j++){
            int d = g[n-1][j]-g[i-1][j]-g[n-i][j];
            if(d < cnt[j]){
                flag = false;
                break;
            }
        }
        if(flag) {
			ret.push_back(i);
			if(i==(n-1)/2+1 && (n&1)) miden = true;
        }
    }
    tmp.clear();
    tmp = ret;
    if(n&1){
    	int i;
    	if(miden) i = tmp.size()-2;
    	else i = tmp.size()-1;
        for(; i >= 0; i--){
            ret.push_back(n+1-tmp[i]);
        }
    }else{
        for(int i = tmp.size()-1; i >= 0; i--){
            ret.push_back(n+1-tmp[i]);
        }
    }
    printf("%d\n",ret.size());
    if(ret.size()){
        printf("%d",ret[0]);
        for(int i = 1; i < ret.size(); i++){
            printf(" %d",ret[i]);
        }

    }
    puts("");
}
int main(){
    //freopen("test.txt","r",stdin);
    getPrime();
    while(~scanf("%d%d",&n,&m)){
        init();
        solve();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值