POJ 2392(多重背包)

3 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u


Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000).

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS:

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

USACO 2005 March Gold

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Cow
{
    int h;
    int a;
    int n;
}c[405];
int dp[40010];
bool cmp (Cow x, Cow y)
{
    return x.a < y.a;
}
void ZeroOnePack(int cost,int weight,int lim)
{
    for(int i=lim;i>=cost;i--)
       dp[i]=max(dp[i],dp[i-cost]+weight);
}
//完全背包
void CompletePack(int cost,int weight,int lim)
{
    for(int i=cost;i<=lim;i++)
      dp[i]=max(dp[i],dp[i-cost]+weight);
}
//多重背包
void MultiplePack(int cost,int weight,int amount,int lim)
{
    if(cost*amount>=lim) CompletePack(cost,weight,lim);
    else
    {
        for(int k=1;k<amount;)
        {
            ZeroOnePack(k*cost,k*weight,lim);
            amount-=k;
            k<<=1;
        }
        ZeroOnePack(amount*cost,amount*weight,lim);
    }
}
int main()
{
    int k,ans,maxh;
    while(scanf("%d", &k) != EOF)
    {
        maxh = ans = -1;
        for(int i = 1;i <= k;i ++)
        {
         scanf("%d%d%d",&c[i].h, &c[i].a, &c[i].n);
         maxh = max(maxh, c[i].a);
        }
        sort(c+1, c+k+1, cmp);
        memset(dp, 0, sizeof(dp));
        for(int i = 1;i <= k;i ++)
        {
           MultiplePack(c[i].h, c[i].h , c[i].n , c[i].a);
        }
        for(int i = 0;i <= maxh;i ++)
            ans = max(dp[i], ans);
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值