数据结构实验之链表一:顺序建立链表

Problem Description
输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。
Input
第一行输入整数的个数N;
第二行依次输入每个整数。
Output
输出这组整数。
Sample Input
8
12 56 4 6 55 15 33 62
Sample Output
12 56 4 6 55 15 33 62
Hint

不得使用数组!

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int i,n;
    struct node *p,*head,*q;
    head = (struct node *)malloc (sizeof(struct  node));//建立一个头结点
    head ->next =NULL;//建立一个空链表
    q=head;
    scanf("%d",&n);
    for(i = 1;i<=n;i++)
    {

        p = (struct node *)malloc(sizeof (struct node));//给p分配一个空间
        scanf("%d",&p->data);
        p->next = NULL;
        q->next = p;
        q=p;//连接
    }
    p = head ->next;//令p为第一个数据
    while (p)//输出
    {
        if(p->next)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p = p->next;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值