HDU1754

I Hate It

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 55422 Accepted Submission(s): 21645

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<<=200000,0<<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output
对于每一次询问操作,在一行里面输出最高成绩。

Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output
5
6
5
9

简单线段树

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"

#define MAXSIZE 200002

using namespace std;


int max(int a, int b)
{
    if (a > b)
        return a;
    else
        return b;
}
int min(int a, int b)
{
    if (a < b)
        return a;
    else
        return b;
}
int n, m;
int num[MAXSIZE];


typedef struct
{
    int max;
    int left, right;
}NODE;



NODE tree[MAXSIZE * 20];


int build(int root,int lf,int rt)
{
    int mid;
    tree[root].left = lf;
    tree[root].right = rt;
    if (lf == rt)
        return tree[root].max = num[lf];
    mid = (lf + rt) / 2;
    int a, b;
    a = build(2 * root, lf, mid);
    b = build(2 * root + 1, mid + 1, rt);

    return tree[root].max = max(a, b);
}

int find(int root, int lf, int rt)
{
    int mid;
    if (tree[root].left > rt || tree[root].right < lf)
        return 0;
    if (lf <= tree[root].left&&tree[root].right <= rt)
        return tree[root].max;
    int a, b;
    a = find(2 * root, lf, rt);
    b = find(2*root + 1, lf, rt);

    return max(a, b);

}

int update(int root, int pos, int val)
{
    if (pos < tree[root].left || tree[root].right < pos)
        return tree[root].max;
    if (tree[root].left == pos&&tree[root].right == pos)
        return tree[root].max = val;

    int a, b;
    a = update(2 * root, pos, val);
    b = update(2 * root + 1, pos, val);

    tree[root].max = max(a, b);
    return tree[root].max;


}


int main()
{
    while (scanf("%d%d", &n, &m) != EOF)
    {
        for (int i = 1; i <= n; i++)
            scanf("%d", &num[i]);
        build(1, 1, n);
        for (int i = 1; i <= m; i++)
        {
            getchar();
            char c;
            int x, y;
            scanf("%c%d%d", &c, &x, &y);
            if (c == 'Q')
                printf("%d\n", find(1, x, y));
            else
            {
                num[x] = y;
                update(1, x, y);
            }
        }

    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值