HDU 5783 Divide the Sequence 2016 Multi-University Training Contest 5

Divide the Sequence

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2232 Accepted Submission(s): 628

Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.

Input
The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2⋯An.
1≤n≤1e6
−10000≤A[i]≤10000
You can assume that there is at least one solution.

Output
For each test case, output an integer indicates the maximum number of sequence division.

Sample Input
6
1 2 3 4 5 6
4
1 2 -3 0
5
0 0 0 0 0

Sample Output
6
2
5
给出一个串问最多可以分割成几个任意前缀和是>=0的子串。
补多校题。发现这不是大水题吗从后往前倒着贪心一下维护sum就好了。。为什么过得比最后一题还少。。。这代码才几行

#include <cstdio>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAX 1000005
long long num[MAX];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%lld",&num[i]);
        long long ans=0,sum=0;
        for(int i=n;i>=1;i--)
        {
            if(sum+num[i]>=0)
            {
                ans++;
                sum=0;
            }
            else
            {
                sum+=num[i];
            }
        }
        printf("%lld\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值