HDU 5410 CRB and His Birthday (01背包+完全背包)

CRB and His Birthday

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1648 Accepted Submission(s): 777

Problem Description
Today is CRB’s birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M Won(currency unit).
At the shop, there are N kinds of presents.
It costs Wi Won to buy one present of i-th kind. (So it costs k × Wi Won to buy k of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi candies if she buys x(x>0) presents of i-th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T ≤ 20
1 ≤ M ≤ 2000
1 ≤ N ≤ 1000
0 ≤ Ai, Bi ≤ 2000
1 ≤ Wi ≤ 2000

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers M and N.
Then N lines follow, i-th line contains three space separated integers Wi, Ai and Bi.

Output
For each test case, output the maximum candies she can gain.

Sample Input
1
100 2
10 2 1
20 1 1

Sample Output
21
Hint
CRB’s mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.

Author
KUT(DPRK)

Source
2015 Multi-University Training Contest 10

Recommend
wange2014 | We have carefully selected several similar problems for you: 5831 5830 5829 5828 5827

大水题。你会发现Ai × x + Bi实际上可以看成两次背包,第一次每一个物品是ai+bi,这是01背包,因为显然不管是哪个b最多只会被取一次(或者说不管取哪个 在第一次取的时候需要加上bi)。第二遍背包时就变成一个裸完全背包了。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
#include "algorithm"
using namespace std;
int a[2005],b[2005],w[2005];
int dp[2005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m,n;
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&m,&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&w[i],&a[i],&b[i]);
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=m;j>=w[i];j--)
            {
                dp[j]=max(dp[j],dp[j-w[i]]+a[i]+b[i]);
            }
            for(int j=w[i];j<=m;j++)
            {
                dp[j]=max(dp[j],dp[j-w[i]]+a[i]);
            }
        }
        printf("%d\n",dp[m]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值