HDU 2476 String painter (区间DP)

String painter

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3524 Accepted Submission(s): 1639

Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output
A single line contains one integer representing the answer.

Sample Input
zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output
6
7

Source
2008 Asia Regional Chengdu

Recommend
lcy | We have carefully selected several similar problems for you: 2480 2481 2478 2482 2475

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
#include "cmath"
#include "algorithm"
using namespace std;
int main()
{
    char a[105],b[105];
    int dp[105][105];
    while(~scanf("%s%s",a,b))
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<strlen(a);i++)
            dp[i][i]=1;
        //枚举不同长度的所有区间
        for(int len=2;len<=strlen(a);len++)
        {
            for(int i=0;i+len-1<=strlen(a)-1;i++)
            {
                int end=i+len-1;
                dp[i][end]=dp[i+1][end]+1;
                //枚举分割点 对于字符串b,只有将相同字符一起刷才能减少操作数。所以每次碰到b[i]==b[k]时,可以减少一次操作,因为刷一次[i,k]再刷[i+1,k-1]和分别刷[i,i][k,k],[i+,k,k+1]是一样的,可操作数会减少。
                for(int j=i+1;j<=end;j++)
                {
                    if(b[i]==b[j])
                        dp[i][end]=min(dp[i][end],dp[i+1][j]+dp[j+1][end]);
                }
            }
        }

        //如果a b对应位置本来就相等 那么可能会有更优解
        int ans[105];
        memset(ans,0,sizeof(105));
        for(int i=0;i<strlen(a);i++)
            ans[i]=dp[0][i];
        for(int i=0;i<strlen(a);i++)
        {
            if(a[i]==b[i])
            {
                if(i==0)
                    ans[i]=0;
                else
                    ans[i]=ans[i-1];
            }
            else
            {
                for(int j=0;j<i;j++)
                    ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
            }
        }
        printf("%d\n",ans[strlen(a)-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值