POJ 1947 Rebuilding Roads ( 树形DP )

Rebuilding Roads
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11258 Accepted: 5190
Description

The cows have reconstructed Farmer John’s farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn’t have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.
Input

  • Line 1: Two integers, N and P

  • Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J’s parent in the tree of roads.
    Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.
Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11
Sample Output

2
Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.]
Source

USACO 2002 February

题意:

农场之间以树形的方式连接,问只要断几条边。就可以有P个点被孤立出来

思路:

dp[s][i]:记录s结点,要得到一棵i个节点的子树去掉的最少边数
考虑其儿子k
1)如果不去掉k子树,则
dp[s][i] = min( dp[s][i], dp[s][j] + dp[k][i-j ]) 0 <= j <= i

2)如果去掉k子树,则
dp[s][i] = dp[s][i]+1;

代码:

#include "cstring"
#include "cstdio"
#include "string.h"
#include "iostream"
#include "cmath"
using namespace  std;
int fa[155];
int dp[155][155];
int n,p;

void dfs(int root)
{
    for(int j=1;j<=p;j++)
        dp[root][j]=0x3f3f3f3f;
    dp[root][1]=0;
    for(int i=1;i<=n;i++)
    {
        if(fa[i]==root)
        {
            dfs(i);
            int Min;
            for(int j=p;j>=1;j--)
            {
                Min=dp[root][j]+1;
                for(int k=1;j-k>=1;k++)
                {
                    Min=min(Min,dp[i][j-k]+dp[root][k]);
                }
                dp[root][j]=Min;
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&p))
    {
        memset(fa,-1,sizeof(fa));
        for(int i=1;i<=n-1;i++)
        {
            int par,son;
            scanf("%d%d",&par,&son);
            fa[son]=par;
        }
        int root;
        for(int i=1;i<=n;i++)
        {
            if(fa[i]==-1)
            {
                root=i;
                break;
            }
        }
        dfs(root);
        int ans = dp[root][p];
        for( int i = 1; i <= n; i++ )
            ans = min(ans,dp[i][p]+1);
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值