1042 Shuffling Machine (20分) 洗牌机器

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目大意:

洗牌是一个打乱牌的过程。由于传统的洗牌技术不太强,并且可能会存在作弊的情况,所以很多赌场都是用自动洗牌机来洗牌。你的任务就是模仿自动洗牌机。

自动洗牌机会随机打乱牌的顺序并根据给出的数字重复洗牌多次。假设一副牌初始的顺序如下:

S1, S2, ..., S13,

H1, H2, ..., H13,

C1, C2, ..., C13,

D1, D2, ..., D13,

J1, J2

其中S代表黑桃,H代表红桃,C代表梅花,D代表方块,J代表王,给出的牌的位置是[1,54]。如果在第i个位置上的数字是j,那么就代表要把第i个位置上的牌移动到位置j上。比如当我们只有5张牌: S3, H5, C1, D13,J2,给出了洗牌的顺序{4, 2, 5, 3, 1},就代表要把第1个位置上的S3换到第4个位置,第2个位置的H5换到第2个位置...得到的结果为J2, H5, D13, S3, C1。如果要洗两次牌,那么最后的结果就为C1, H5, S3, J2, D13。

解题思路:

构造一个结构体Card,存储每张牌的位置和花色,用一个Card数组存储下每张牌的信息。每次洗牌时修改牌的位置即可。

注意点:

  • 每次洗完牌后要重新排序(sort函数,按照Card中的pos重新排序),因为牌的位置Card中的pos有更新,而洗牌的数组position是不变的,其仅仅对应某个位置上的牌需要换到某个位置。
  • 初始时每张牌的pos从1到54,按照题目中给出的花色S1,S2...来。

代码如下:

#include<iostream>
#include<algorithm>
#include<sstream>
using namespace std;
struct Card{
	int pos;
	string number;
};
bool compare(Card a,Card b){
	return a.pos < b.pos;
}
int main(){
	//初始化 
	Card cards[55];
	for(int i = 1 ; i <= 54 ; i ++){
		string number;
		int a = i / 13;
		int b = i % 13;
		if(b == 0){
			a --;
			b = 13;
		}
		stringstream ss;
		ss << b;
		string c;
		ss >> c;
		switch(a){
			case 0:number = "S" + c;break;
			case 1:number = "H" + c;break;
			case 2:number = "C" + c;break;
			case 3:number = "D" + c;break;
			case 4:number = "J" + c;break;
			default:break;
		} 
		cards[i].number = number;
		cards[i].pos = i;
	}
	//洗牌
	int repeat;
	scanf("%d",&repeat);
	int position[55];
	for(int i = 1 ; i <= 54 ; i ++)
		scanf("%d",&position[i]);
	while(repeat--){
		for(int i = 1 ; i <= 54 ; i ++){
			cards[i].pos = position[i];
		}
		sort(cards+1,cards+55,compare);
	}
	for(int i = 1 ; i <= 54 ; i ++){
		if(i > 1)
			printf(" ");
		cout<<cards[i].number;
	}
	return 0; 
}

想复杂了,更新代码如下:

#include<iostream>
using namespace std;
int main(){
	int start[55],end[55],change[55],K;
	for(int i = 1 ; i <= 54 ; i ++)//初始化 
		start[i] = i;
	scanf("%d",&K);
	for(int i = 1 ; i <= 54 ; i ++)
		scanf("%d",&change[i]);
	while(K--){
		for(int i = 1 ; i <= 54 ; i ++)//change[i]位置上的值变成了i位置上的值 
			end[change[i]] = start[i];
		for(int i = 1 ; i <= 54 ; i ++)//更新位置 
			start[i] = end[i];
	}
	char color[5] = {'S','H','C','D','J'};
	for(int i = 1 ; i <= 54 ; i ++){
		if(i > 1)
			printf(" ");
		start[i] --;
		printf("%c%d",color[start[i] / 13],start[i] % 13 + 1);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值