1045 Favorite Color Stripe (30分)动态规划求最长非递减子序列

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10^{4}) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

题目大意:

Eva有喜爱的颜色序列如{2 3 1 5 6},现给出一个颜色序列{2 2 4 1 5 5 6 3 1 1 5 6},问怎样从中抽取出符合Eva喜爱的颜色排列的最长子序列,不用包含Eva喜欢的所有颜色,只需要子序列中的颜色顺序按照她喜欢的颜色顺序排列就可以。比如以上的例子中就可以找到四个符合要求的最长子序列:{2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6},  {2 2 3 1 1 5 6}。

解题思路:

参考博客:https://blog.csdn.net/renly123/article/details/104790042

可以将该题目转化为求最长非递减子序列的问题。

将Eva喜爱的颜色用数组下标表示,比如{2 3 1 5 6}替换为{1,2,3,4,5},那么题目给出的颜色序列{2 2 4 1 5 5 6 3 1 1 5 6}就会被表示为{1,1,3,4,4,5,2,3,3,4,5}(注意其中4不在Eva喜爱的颜色序列中,所以直接去掉不表示)。之后题目就变成了求解{1,1,3,4,4,5,2,3,3,4,5}中符合{1,2,3,4,5}排序的最长子序列(不必包含{1,2,3,4,5}中的所有数字),也即求解{1,1,3,4,4,5,2,3,3,4,5}的非递减最长子序列,这下子就知道该怎么做了。

这里用动态规划来求解非递减最长子序列问题:

dp[i]表示以list[i]结尾的非递减最长子序列的长度,j < i,如果list[i] >= list[j],表示list[i]可以接在以list[j]结尾的最长子序列的后面,即dp[i] = dp[j] + 1,边界值dp[i] = 1。

由此,dp[i] = max(dp[i],dp[j]+1)或 = 1。

这里要注意的是测试点2:可能存在给出的颜色序列中的所有颜色都不是Eva喜欢的颜色,此时最长非递减子序列的值为2。

测试点2参考博客:https://blog.csdn.net/allisonshing/article/details/102811357

代码如下:

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int main(){
	int N,M,L,temp;
	scanf("%d",&N);
	int *color = new int[N+1];
	memset(color,0,sizeof(color));
	scanf("%d",&M);
	for(int i = 1 ; i <= M ; i ++){
		scanf("%d",&temp);
		color[temp] = i;
	}
	scanf("%d",&L);
	vector<int> list;
	for(int i = 1 ; i <= L ; i ++){
		scanf("%d",&temp);
		if(color[temp] != 0){
			list.push_back(color[temp]);	
		}
		
	}
	//动态规划求最大非递减子序列长度
	int maxL = 0;
	int *dp = new int[list.size()];//存储到i的最长非递减子序列长度 
	for(int i = 0 ; i < list.size() ; i ++){
		dp[i] = 1; 
		for(int j = 0 ; j < i ; j ++){
			if(list[j] <= list[i])
				dp[i] = max(dp[i],dp[j]+1);
		}
		maxL = max(maxL,dp[i]);
	}
	printf("%d",maxL);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值